Red Hat Security AdvisoryRHSA-2021:1512
postgresql security update
Released 2021-05-06 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux Client (v. 7) postgresql-9.2.24-6.el7_9, postgresql-libs-9.2.24-6.el7_9
- Red Hat Enterprise Linux Client Optional (v. 7) postgresql-9.2.24-6.el7_9, postgresql-contrib-9.2.24-6.el7_9, postgresql-devel-9.2.24-6.el7_9 +8
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) postgresql-9.2.24-6.el7_9, postgresql-contrib-9.2.24-6.el7_9, postgresql-devel-9.2.24-6.el7_9 +8
- Red Hat Enterprise Linux Server (v. 7) postgresql-9.2.24-6.el7_9, postgresql-9.2.24-6.el7_9.ppc, postgresql-contrib-9.2.24-6.el7_9 +10
- Red Hat Enterprise Linux Server Optional (v. 7) postgresql-static-9.2.24-6.el7_9, postgresql-static-9.2.24-6.el7_9.ppc, postgresql-upgrade-9.2.24-6.el7_9
- Red Hat Enterprise Linux Workstation (v. 7) postgresql-9.2.24-6.el7_9, postgresql-contrib-9.2.24-6.el7_9, postgresql-devel-9.2.24-6.el7_9 +6
- Red Hat Enterprise Linux Workstation Optional (v. 7) postgresql-docs-9.2.24-6.el7_9, postgresql-static-9.2.24-6.el7_9, postgresql-upgrade-9.2.24-6.el7_9
Fixes 3 records
Priority HIGH 68
A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.4644 · Published 2020-11-16 · Partial fix CWE-89
Priority MEDIUM 42
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02188 · Published 2019-10-29 · Partial fix CWE-89
Priority LOW 38
A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.01593 · Published 2020-11-16 · Partial fix CWE-327