Red Hat Security AdvisoryRHSA-2024:1545
dnsmasq security update
Released 2024-03-27 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux AppStream EUS (v.8.6) dnsmasq-2.79-21.el8_6.5, dnsmasq-utils-2.79-21.el8_6.5
Fixes 4 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority MEDIUM 44
A single-byte, non-arbitrary write/use-after-free flaw was found in dnsmasq.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02644 · Published 2022-08-29 · Partial fix CWE-416
Priority MEDIUM 43
An issue was discovered in Dnsmasq before 2.90.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01838 · Published 2023-03-15 · Partial fix