Red Hat Security AdvisoryRHSA-2024:2587
unbound security update
Released 2024-04-30 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux AppStream AUS (v.8.4) python3-unbound-1.7.3-15.el8_4.1, unbound-1.7.3-15.el8_4.1, unbound-devel-1.7.3-15.el8_4.1 +1
- Red Hat Enterprise Linux AppStream E4S (v.8.4) python3-unbound-1.7.3-15.el8_4.1, unbound-1.7.3-15.el8_4.1, unbound-devel-1.7.3-15.el8_4.1 +1
- Red Hat Enterprise Linux AppStream TUS (v.8.4) python3-unbound-1.7.3-15.el8_4.1, unbound-1.7.3-15.el8_4.1, unbound-devel-1.7.3-15.el8_4.1 +1
Fixes 3 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority LOW 35
A vulnerability was found in Unbound due to incorrect default permissions, allowing any process outside the unbound group to modify the unbound runtime configuration.
CVSS 3.1HIGH 8.0· Local · No auth · No interaction · EPSS 0.00321 · Published 2024-02-15 · Partial fix · 1.16.2-5.el8_9.6, 1.16.2-5.8.el8_10 +7 CWE-276