Red Hat Security AdvisoryRHSA-2024:3877
dnsmasq security update
Released 2024-06-13 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux AppStream AUS (v.8.4) dnsmasq-2.79-15.el8_4.2, dnsmasq-utils-2.79-15.el8_4.2
- Red Hat Enterprise Linux AppStream E4S (v.8.4) dnsmasq-2.79-15.el8_4.2, dnsmasq-utils-2.79-15.el8_4.2
- Red Hat Enterprise Linux AppStream TUS (v.8.4) dnsmasq-2.79-15.el8_4.2, dnsmasq-utils-2.79-15.el8_4.2
Fixes 2 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400