Read the docs
Red Hat Security Advisory

RHSA-2026:53371

Insights proxy Container Image

Released 2026-08-11 · Red Hat rating Important · View on Red Hat →

Fixed in

Fixes 35 records

TI-2026-05203 CVE-2026-5928 · GHSA-829p-mc9m-7xhr

Potential buffer under-read in ungetwc

Priority HIGH 72

Calling the ungetwc function on a FILE stream with wide characters encoded in a character set that has overlaps between its single byte and multi-byte character encodings, in the GNU C Library version 2.43 or earlier, ma…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00369 Published 2026-04-20 Partial fix CWE-127
TI-2026-12417 CVE-2026-14739 · GHSA-w9gf-c5hh-cc8w

Out-of-bounds write in HMBRAND DBI

Priority MEDIUM 49

DBI versions before 1.650 for Perl have a heap overflow when preparsing SQL statements with an extreme number of placeholders.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00413 Published 2026-07-07 Partial fix · 1.650 CWE-787
TI-2026-09339 CVE-2026-10879 · GHSA-c7xw-cj86-m724

Out-of-bounds write in HMBRAND DBI

Priority MEDIUM 49

DBI versions before 1.648 for Perl have a heap overflow when preparsing SQL statements with more than 9 binders.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00485 Published 2026-06-05 Partial fix · 1.648 CWE-787
Priority MEDIUM 48

A path handling issue in mod_dav_fs in Apache 2.4.67 and earlier allows a WebDAV content author to directly manipulate trusted DAV property databases, potentially causing child process crashes.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00538 Published 2026-06-08 Partial fix CWE-668
TI-2026-08500 CVE-2026-9698 · GHSA-83j7-3c78-fq8j

Out-of-bounds write in HMBRAND DBI

Priority MEDIUM 48

DBI versions before 1.648 for Perl saved errors in a limited-sized buffer.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00464 Published 2026-06-09 Partial fix · 1.648 CWE-787
Priority MEDIUM 41

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01024 Published 2026-06-08 Partial fix CWE-122
Priority MEDIUM 41

A buffer overflow in mod_proxy_html in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01161 Published 2026-06-08 Partial fix CWE-122
Priority MEDIUM 41

An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00654 Published 2026-05-04 Partial fix CWE-269
Priority MEDIUM 40

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with malicious backend servers and ProxyPassReverseCookie* This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00708 Published 2026-06-08 Fixed CWE-122
Priority MEDIUM 40

A NULL pointer dereference in mod_dav_lock in Apache HTTP Server 2.4.66 and earlier may allow an attacker to crash the server with a malicious request.mod_dav_lock is not used internally by mod_dav or mod_dav_fs.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00594 Published 2026-05-04 Partial fix CWE-476
TI-2024-28481 CVE-2024-42516 · GHSA-5j7h-7m92-jgh4

Apache HTTP Server: HTTP response splitting

Priority MEDIUM 40

HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00818 Published 2025-07-10 Partial fix CWE-20
Priority LOW 39

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in the mod_proxy_ftp module in Apache HTTP Server with an attacker controlled backend FTP server.

CVSS 3.1HIGH 7.3 Network No auth No interaction EPSS 0.00583 Published 2026-06-08 Partial fix CWE-835
Priority LOW 39

Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

CVSS 3.1HIGH 7.3 Network No auth No interaction EPSS 0.00741 Published 2026-06-08 Partial fix CWE-126
Priority LOW 38

The deprecated functions ns_printrrf, ns_printrr and fp_nquery in the GNU C Library version 2.2 and newer fail to enforce the caller-supplied buffer length, and can result in an out-of-bounds write when printing TSIG rec…

CVSS 3.1HIGH 7.3 Network No auth No interaction EPSS 0.00237 Published 2026-04-28 Partial fix CWE-787
Priority LOW 37

acl before version 2.4.0 contains a symlink traversal vulnerability in the libacl pathname-based functions acl_get_file(), acl_set_file(), acl_extended_file(), and acl_delete_def_file() that allows local attackers to esc…

CVSS 4.0HIGH 8.4 Local Low privileges No interaction EPSS 0.00153 Published 2026-06-29 Partial fix · 2.4.0 CWE-59
Priority LOW 35

The deprecated functions ns_printrrf, ns_printrr and fp_nquery in the GNU C Library version 2.0.1 to version 2.43 fail to validate the RDATA content against the RDATA length in a DNS response when processing A6, CERT, LO…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00358 Published 2026-04-28 Fixed CWE-126
Priority LOW 32

acl before version 2.4.0 contains a time-of-check to time-of-use (TOCTOU) race condition vulnerability that allows local attackers to escalate privileges by replacing a pathname component with a symbolic link between an…

CVSS 4.0HIGH 7.2 Local Low privileges No interaction EPSS 0.00088 Published 2026-06-29 Partial fix · 2.4.0 CWE-367
TI-2026-30383 CVE-2026-41989 · GHSA-wrv8-79m2-qg24

Out-of-bounds write in GnuPG Libgcrypt

Priority LOW 29

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

CVSS 3.1MEDIUM 6.7 Local No auth No interaction EPSS 0.00182 Published 2026-04-23 Fixed in 1.10.4, 1.11.3 +1 CWE-787
Priority LOW 23

A timing attack against mod_auth_digest in Apache HTTP Server 2.4.66 allows a bypass of Digest authentication by a remote attacker.

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00557 Published 2026-05-04 Partial fix CWE-208