Read the docs

Adobe

Records8047All Threatist records
Exploited (KEV)83In CISA KEV
CVSS critical1940CVSS 9.0–10.0
CVSS high3102CVSS 7.0–8.9

Exploited now

Adobe records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

109 records in Animate · all components

Priority MEDIUM 58

Adobe Animate versions 15.2.1.95 and earlier have an exploitable memory corruption vulnerability.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.15785 Published 2016-12-15 No fix listed CWE-119
Priority MEDIUM 47

Adobe Animate version 21.0.3 (and earlier) is affected by a Heap-based Buffer Overflow vulnerability.

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.08305 Published 2021-03-12 No fix listed CWE-122
Priority MEDIUM 44

Adobe Animate version 21.0.3 (and earlier) is affected by a Memory Corruption vulnerability.

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.04611 Published 2021-03-12 No fix listed CWE-787
Priority MEDIUM 43

Adobe Animate version 21.0.9 (and earlier) are affected by a use-after-free vulnerability in the processing of a malformed FLA file that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.03997 Published 2021-11-18 No fix listed CWE-416
Priority MEDIUM 43

Adobe Animate version 20.5 (and earlier) is affected by a stack overflow vulnerability, which could lead to arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.06271 Published 2020-10-21 No fix listed CWE-121
Priority MEDIUM 41

Adobe Animate version 21.0.9 (and earlier) is affected by a memory corruption vulnerability due to insecure handling of a malicious FLA file, potentially resulting in arbitrary code execution in the context of the curren…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.0255 Published 2021-11-18 No fix listed CWE-788
Priority MEDIUM 41

Adobe Animate version 21.0.9 (and earlier) is affected by a memory corruption vulnerability due to insecure handling of a malicious FLA file, potentially resulting in arbitrary code execution in the context of the curren…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.02484 Published 2021-11-18 No fix listed CWE-788
Priority MEDIUM 41

Adobe Animate version 21.0.9 (and earlier) is affected by a memory corruption vulnerability due to insecure handling of a malicious .psd file, potentially resulting in arbitrary code execution in the context of the curre…

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.0261 Published 2021-11-18 No fix listed CWE-788
Priority MEDIUM 41

Adobe Animate version 20.5 (and earlier) is affected by an out-of-bounds read vulnerability, which could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.04503 Published 2020-10-21 No fix listed CWE-125
Priority MEDIUM 41

Adobe Animate version 20.5 (and earlier) is affected by an out-of-bounds read vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.04147 Published 2020-10-21 No fix listed CWE-125
Priority MEDIUM 41

Adobe Animate version 20.5 (and earlier) is affected by a double free vulnerability when parsing a crafted .fla file, which could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.04147 Published 2020-10-21 No fix listed CWE-415
Priority LOW 39

Animate is affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.2 Local Low privileges User interaction EPSS 0.00891 Published 2026-07-14 Fixed in 23.0.16, 24.0.14 CWE-78
Priority LOW 38

Adobe Animate version 21.0 (and earlier) is affected by an uncontrolled search path element that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.0 Local No auth User interaction EPSS 0.02452 Published 2021-01-13 No fix listed CWE-427
Priority LOW 37

Animate is affected by an Improper Control of Generation of Code ('Code Injection') vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.2 Local Low privileges User interaction EPSS 0.00242 Published 2026-09-08 Fixed in 23.0.17, 24.0.15 CWE-94
Load more
Open these records in search →