Priority HIGH 78
Buffer overflow in Adobe Illustrator CS4 14.0.0, CS3 13.0.3 and earlier, and CS3 13.0.0 allows remote attackers to execute arbitrary code via a long DSC comment in an Encapsulated PostScript (.eps) file.
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.70684 · Published 2009-12-04 · No fix listed CWE-119
Priority HIGH 68
Buffer overflow in Adobe Photoshop CS2 and CS3, Photoshop Elements 5.0, Illustrator CS3, and GoLive 9 allows user-assisted remote attackers to execute arbitrary code via a crafted .PNG file.
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.41196 · Published 2007-04-30 · No fix listed CWE-119
Priority MEDIUM 64
Multiple buffer overflows in Adobe Photoshop CS2 and CS3, Illustrator CS3, and GoLive 9 allow user-assisted remote attackers to execute arbitrary code via a crafted (1) BMP, (2) DIB, or (3) RLE file.
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.3171 · Published 2007-04-25 · No fix listed CWE-119
Priority MEDIUM 59
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-2023, CVE-2012-2024, CVE-2012-2025…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.15002 · Published 2012-05-09 · No fix listed CWE-119
Priority MEDIUM 57
Untrusted search path vulnerability in Adobe Illustrator CS4 14.0.0, CS5 15.0.1 and earlier, and possibly other versions allows local users, and possibly remote attackers, to execute arbitrary code and conduct DLL hijack…
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.16846 · Published 2010-08-27 · No fix listed
Priority MEDIUM 54
Buffer overflow in Adobe Illustrator CS3 13.0.3 and earlier and Illustrator CS4 14.0.0 allows attackers to execute arbitrary code via unspecified vectors.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.07967 · Published 2010-01-08 · No fix listed CWE-119
Priority MEDIUM 51
Stack-based buffer overflow in Adobe Illustrator CS6 before 16.0.5 and 16.2.x before 16.2.2 allows remote attackers to execute arbitrary code via unspecified vectors.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.05599 · Published 2014-05-14 · No fix listed CWE-119
Priority MEDIUM 51
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-0780, CVE-2012-2023, CVE-2012-2024…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.05322 · Published 2012-05-09 · No fix listed CWE-119
Priority MEDIUM 51
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-0780, CVE-2012-2023, CVE-2012-2024…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.05322 · Published 2012-05-09 · No fix listed CWE-119
Priority MEDIUM 51
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-0780, CVE-2012-2023, CVE-2012-2025…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.05322 · Published 2012-05-09 · No fix listed CWE-119
Priority MEDIUM 51
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-0780, CVE-2012-2024, CVE-2012-2025…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.05322 · Published 2012-05-09 · No fix listed CWE-119
Priority MEDIUM 49
Adobe Illustrator version 25.2 (and earlier) is affected by a memory corruption vulnerability when parsing a specially crafted file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.07996 · Published 2021-09-08 · No fix listed CWE-788
Priority MEDIUM 49
Adobe Illustrator before CS6 allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-0780, CVE-2012-2023, CVE-2012-2024…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.03711 · Published 2012-05-24 · No fix listed CWE-119
Priority MEDIUM 49
Multiple unspecified vulnerabilities in Adobe Illustrator CS2 on Macintosh allow user-assisted attackers to execute arbitrary code via a crafted AI file.
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.06348 · Published 2008-09-17 · No fix listed
Priority MEDIUM 47
Adobe Illustrator version 25.2 (and earlier) is affected by a memory corruption vulnerability when parsing a specially crafted file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.06561 · Published 2021-09-08 · No fix listed CWE-788
Priority MEDIUM 47
Adobe Illustrator version 25.2 (and earlier) is affected by a Path Traversal vulnerability when parsing a specially crafted file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.0388 · Published 2021-06-28 · No fix listed CWE-22
Priority MEDIUM 45
Adobe Illustrator version 25.2 (and earlier) is affected by a memory corruption vulnerability when parsing a specially crafted file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.04454 · Published 2021-09-08 · No fix listed CWE-788
Priority MEDIUM 44
Illustrator is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user, potentially gaining elevated access or control over the victim's acc…
CVSS 3.1CRITICAL 9.3· Network · No auth · User interaction · EPSS 0.01028 · Published 2026-07-14 · Fixed in 30.6, 29.8.9 CWE-20
Priority MEDIUM 44
Adobe Illustrator version 25.2 (and earlier) is affected by an Out-of-bounds Write vulnerability when parsing a specially crafted file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.03467 · Published 2021-06-28 · No fix listed CWE-787
Priority MEDIUM 43
Adobe Illustrator versions 25.4.3 (and earlier) and 26.0.2 (and earlier) are affected by a buffer overflow vulnerability due to insecure handling of a crafted malicious file, potentially resulting in arbitrary code execu…
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.04443 · Published 2022-02-16 · No fix listed CWE-120
Priority MEDIUM 43
Adobe Illustrator version 26.0.3 (and earlier) is affected by a buffer overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current us…
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.04318 · Published 2022-03-11 · No fix listed CWE-120
Priority MEDIUM 43
Adobe Illustrator version 25.1 (and earlier) is affected by an Out-of-bounds Write vulnerability when parsing a crafted file.
CVSS 3.0HIGH 7.8· Local · No auth · User interaction · EPSS 0.04127 · Published 2021-02-11 · No fix listed CWE-787
Priority MEDIUM 42
Adobe Illustrator version 25.2.3 (and earlier) is affected by a potential Command injection vulnerability when chained with a development and debugging tool for JavaScript scripts.
CVSS 3.1HIGH 8.3· Network · No auth · User interaction · EPSS 0.01917 · Published 2021-08-20 · No fix listed CWE-78
Priority MEDIUM 42
Adobe Illustrator version 24.2 (and earlier) is affected by an out-of-bounds read vulnerability when parsing crafted PDF files.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.04918 · Published 2020-10-20 · No fix listed CWE-125
Priority MEDIUM 42
Adobe Illustrator version 24.2 (and earlier) is affected by an out-of-bounds read vulnerability when parsing crafted PDF files.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.04918 · Published 2020-10-20 · No fix listed CWE-125
Load more