Vendors / Cygwin Records 3 All Threatist records
Exploited (KEV) 0 None in CISA KEV
CVSS critical 1 CVSS 9.0–10.0
CVSS high 2 CVSS 7.0–8.9
Exploited now Cygwin records in CISA KEV No Cygwin vulnerabilities are listed in CISA KEV.
Components Products in the NVD configurations · select one to filter the records Priority MEDIUM 46
Cygwin before 2.5.0 does not properly handle updating permissions when changing users, which allows attackers to gain privileges.
CVSS 3.0 CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0204 · Published 2017-04-21 · No fix listed CWE-264
Priority MEDIUM 41
Cygwin Git is a patch set for the git command line tool for the cygwin environment.
CVSS 3.1 HIGH 8.8· Network · No auth · User interaction · EPSS 0.0124 · Published 2021-04-29 · Fixed in 2.31.1-2 CWE-20
Priority LOW 38
Cygwin versions 1.7.2 up to and including 1.8.0 are vulnerable to buffer overflow vulnerability in wcsxfrm/wcsxfrm_l functions resulting into denial-of-service by crashing the process or potential hijack of the process r…
CVSS 3.0 HIGH 7.5· Network · No auth · No interaction · EPSS 0.02746 · Published 2017-07-21 · No fix listed CWE-787
Open these records in search → All records by CVSS severity
Critical1 High2 Medium0 Low0 No CVSS0