Dify before version 1.14.2 contains an authorization bypass vulnerability that allows authenticated editor users to set and enable trace configurations for any application regardless of tenant ownership.
CVSS 4.0CRITICAL 9.3·Network·No auth·No interaction·EPSS 0.05968·Published 2026-05-18·Fixed in 1.14.2CWE-639
Dify version 1.14.1 and prior contain a path traversal vulnerability that allows authenticated users to manipulate requests forwarded to the Plugin Daemon's internal REST API by exploiting insufficient URL path sanitizat…
Dify before 1.16.0-rc1 contains a SQL injection vulnerability in the MyScale vector store backend that allows attackers to execute arbitrary SQL by supplying unsanitized search parameters to the search_by_full_text metho…
CVSS 4.0HIGH 8.7·Network·Low privileges·No interaction·EPSS 0.00497·Published 2026-07-10·Fixed in 1.16.0-rc1CWE-89
Dify before version 1.14.2 contains an authorization bypass vulnerability in the file preview endpoint that allows any authenticated user to read up to 3,000 characters of any uploaded document across all tenants and wor…
CVSS 4.0HIGH 8.2·Network·No auth·No interaction·EPSS 0.00435·Published 2026-05-18·Fixed in 1.14.2CWE-639