Versions of the package asyncua before 0.9.96 are vulnerable to Denial of Service (DoS) such that an attacker can send a malformed packet and as a result, the server will enter into an infinite loop and consume excessive…
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.01175·Published 2023-10-03·Fixed in 0.9.96CWE-400
Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication.
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.0052·Published 2023-10-03·Fixed in 0.9.96CWE-287
All versions of package freeopcua/freeopcua are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription…