Read the docs

Generex

Records10All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical4CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

Generex records in CISA KEV

No Generex vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

10 records

Priority MEDIUM 52

Generex UPS CS141 below 2.06 version, could allow a remote attacker to upload a firmware file containing a webshell that could allow him to execute arbitrary code as root.

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.0157 Published 2023-03-31 Fixed in 2.06 CWE-20
Priority MEDIUM 47

Generex UPS CS141 below 2.06 version, allows an attacker toupload a firmware file containing an incorrect configuration, in order to disrupt the normal functionality of the device.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00853 Published 2023-03-31 Fixed in 2.06 CWE-20
Priority MEDIUM 45

Generex CS141 through 2.10 allows remote command execution by administrators via a web interface that reaches run_update in /usr/bin/gxserve-update.sh (e.g., command execution can occur via a reverse shell installed by i…

CVSS 3.1CRITICAL 9.1 Network High privileges No interaction EPSS 0.03224 Published 2022-10-06 No fix listed
Priority MEDIUM 43

Generex UPS CS141 below 2.06 version, could allow a remote attacker to upload a backup file containing a modified "users.json" to the web server of the device, allowing him to replace the administrator password.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01301 Published 2023-03-31 Fixed in 2.06 CWE-20
TI-2022-23392 CVE-2022-47188 · GHSA-7j8w-v723-8chg

Improper Input Validation in Generex CS141

Priority MEDIUM 41

There is an arbitrary file reading vulnerability in Generex UPS CS141 below 2.06 version.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00914 Published 2023-03-31 Fixed in 2.06 CWE-20
Priority MEDIUM 40

Generex UPS CS141 below 2.06 version, could allow a remote attacker to upload a firmware file containing a file with modified permissions, allowing him to escalate privileges.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01057 Published 2023-03-31 Fixed in 2.06 CWE-20
Priority LOW 33

There is a file upload XSS vulnerability in Generex CS141 below 2.06 version.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00387 Published 2023-09-28 Fixed in 2.06 CWE-79
Priority LOW 32

Directory traversal vulnerability in RCCMD 4.26 and earlier allows a remote authenticated attacker with an administrative privilege to read or alter an arbitrary file on the server via unspecified vectors.

CVSS 3.1MEDIUM 6.5 Network High privileges No interaction EPSS 0.01581 Published 2022-06-13 No fix listed CWE-22
Open these records in search →