Read the docs

Grandstream

Records57All Threatist records
Exploited (KEV)1In CISA KEV
CVSS critical14CVSS 9.0–10.0
CVSS high32CVSS 7.0–8.9

Exploited now

Grandstream records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

57 records

Priority CRITICAL 100KEV

The HTTP interface of the Grandstream UCM6200 series is vulnerable to an unauthenticated remote SQL injection via crafted HTTP request.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.84287 Published 2020-03-23 Fixed in 1.0.20.17 CWE-89
TI-2024-21804 CVE-2024-32937 · GHSA-6x56-7q94-5745

OS command injection in Grandstream GXP2135

Priority HIGH 65

An os command injection vulnerability exists in the CWMP SelfDefinedTimeZone functionality of Grandstream GXP2135 1.0.9.129, 1.0.11.74 and 1.0.11.79.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.26958 Published 2024-07-03 No fix listed CWE-78
Priority MEDIUM 58

Grandstream GAC2500 1.0.3.35, GXP2200 1.0.3.27, GVC3202 1.0.3.51, GXV3275 before 1.0.3.219 Beta, and GXV3240 before 1.0.3.219 Beta devices allow unauthenticated remote code execution via shell metacharacters in a /manage…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.15475 Published 2019-03-30 No fix listed CWE-119
Priority MEDIUM 57

an attacker with knowledge of user/pass of Grandstream GSD3710 in its 1.0.11.13 version, could overflow the stack since it doesn't check the param length before use the strcopy instruction.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0545 Published 2022-09-23 No fix listed CWE-121
Priority MEDIUM 52

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via HTTP.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.06926 Published 2020-07-17 No fix listed CWE-78
Priority MEDIUM 51

In Grandstream GSD3710 in its 1.0.11.13 version, it's possible to overflow the stack since it doesn't check the param length before using the sscanf instruction.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0584 Published 2022-09-23 No fix listed CWE-121
Priority MEDIUM 49

The Grandstream SIP Phone GXV-3000 with firmware 1.0.1.7, Loader 1.0.0.6, and Boot 1.0.0.18 allows remote attackers to force silent call completion, eavesdrop on the phone's local environment, and cause a denial of servi…

CVSS 2.0HIGH 7.8 Network No auth Interaction — EPSS 0.13642 Published 2007-08-23 No fix listed
Priority MEDIUM 48

Multiple buffer overflows in the limited configuration shell (/sbin/gs_config) on Grandstream HT801 devices before 1.0.29 allow remote authenticated users to execute arbitrary code as root via a crafted manage_if setting…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.07408 Published 2021-10-28 No fix listed CWE-787
Priority MEDIUM 48

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via SSH.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03204 Published 2020-07-17 No fix listed CWE-78
Priority MEDIUM 48

Grandstream GXV3501, GXV3504, GXV3601, GXV3601HD/LL, GXV3611HD/LL, GXV3615W/P, GXV3651FHD, GXV3662HD, GXV3615WP_HD, GXV3500, and possibly other camera models with firmware 1.0.4.11, have a hardcoded account "!#/" with th…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.02602 Published 2019-12-11 No fix listed CWE-798
Priority MEDIUM 47

The Grandstream UCM6200 series before 1.0.20.22 is vulnerable to an SQL injection via the HTTP server's websockify endpoint.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.12164 Published 2020-03-30 No fix listed CWE-89
Priority MEDIUM 46

Grandstream GXP1600 series firmware 1.0.4.152 and below is vulnerable to authenticated remote command execution when an attacker adds an OpenVPN up script to the phone's VPN settings via the "Additional Settings" field i…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.05339 Published 2020-04-14 No fix listed CWE-94
Priority MEDIUM 46

Grandstream GXP1600 series firmware 1.0.4.152 and below is vulnerable to authenticated remote command execution when an attacker uploads a specially crafted tar file to the HTTP /cgi-bin/upload_vpntar interface.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.05424 Published 2020-04-14 No fix listed CWE-59
Priority MEDIUM 45

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via HTTP.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04375 Published 2020-07-17 No fix listed CWE-78
Load more
Open these records in search →