Read the docs

IPFire.org

Records33All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high6CVSS 7.0–8.9

Exploited now

IPFire.org records in CISA KEV

No IPFire.org vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

32 records in Ipfire · all components

Priority MEDIUM 60

IPFire 2.29 DNS management interface (dns.cgi) fails to properly sanitize user-supplied input in the NAMESERVER, REMARK, and TLS_HOSTNAME query parameters, resulting in a reflected cross-site scripting (XSS) vulnerabilit…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00228 Published 2025-08-26 No fix listed CWE-79
Priority MEDIUM 58

IPFire 2.29 web-based firewall interface (firewall.cgi) fails to sanitize several rule parameters such as PROT, SRC_PORT, TGT_PORT, dnatport, key, ruleremark, src_addr, std_net_tgt, and tgt_addr, allowing an authenticate…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00283 Published 2025-08-26 No fix listed CWE-79
Priority MEDIUM 54

IPFire versions prior to 2.29 (Core Update 198) contain a command injection vulnerability that allows an authenticated attacker to execute arbitrary commands as the user 'nobody' via multiple parameters when creating a P…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.13451 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-78
Priority MEDIUM 44

IPFire versions prior to 2.29 (Core Update 198) contain a command injection vulnerability that allows an authenticated attacker to execute arbitrary commands as the 'nobody' user via the BE_NAME parameter when installing…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.02238 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-78
Priority LOW 31

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the SERVICE, LOGIN, and PASSWORD…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.05324 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 31

IPFire versions prior to 2.29 (Core Update 198) contain a SQL injection vulnerability that allows an authenticated attacker to manipulate the SQL query used when viewing OpenVPN connection logs via the CONNECTION_NAME pa…

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00415 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-89
Priority LOW 31

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code into the COUNTRY_CODE parameter when cre…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.05324 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 26

An authenticated Stored Cross-Site Scriptiong (XSS) vulnerability exists in Lightning Wire Labs IPFire 2.21 (x86_64) - Core Update 130 in the "routing.cgi" Routing Table Entries via the "Remark" text box or "remark" para…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00741 Published 2021-07-12 No fix listed CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the TLS_HOSTNAME parameter when…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the txt_mailuser and txt_mailpas…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the REMOTELOG_ADDR parameter whe…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the SRC, DST, and COMMENT parame…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the QUOTA_USERS parameter when c…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the INC_SPD, OUT_SPD, DEFCLASS_I…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the UPDATE_VALUE parameter when…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the pienumber parameter when upd…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the pienumber parameter when upd…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain multiple stored cross-site scripting (XSS) vulnerabilities caused by a bug in the cleanhtml() function (/var/ipfire/header.pl) that fails to apply HTML-entity encod…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Priority LOW 24

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the IGNORE_ENTRY_REMARK paramete…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00485 Published 2025-10-28 Fixed in 2.29 (Core Update 198) CWE-79
Load more
Open these records in search →