Configurable Reports block for Moodle before 5.3.0 contains an authorization bypass vulnerability that allows authenticated users to read restricted reports through the block_configurable_reports_get_report_data web serv…
CVSS 4.0HIGH 7.1·Network·Low privileges·No interaction·EPSS 0.00424·Published 2026-10-20·Fixed in 5.3.0CWE-863
Configurable Reports block for Moodle (moodle-block_configurablereports) before 5.3.1 contains an sql injection vulnerability in report_sql::prepare_sql() via the filter_var request parameter of viewreport.php.
CVSS 4.0MEDIUM 6.0·Network·Low privileges·No interaction·EPSS 0.00391·Published 2026-10-20·Fixed in 5.3.1CWE-89