Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.
CVSS 3.1HIGH 8.4·Local·No auth·No interaction·EPSS 0.00333·Published 2025-11-18·Fixed in 25.6.0CWE-502