Read the docs

Jovancoding

Records20All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

Jovancoding records in CISA KEV

No Jovancoding vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

20 records

Priority HIGH 79

Network-AI (npm: network-ai) versions 5.12.2 through 5.13.3 fail to apply the configured authorization check (checkAuth/secret) to the ApprovalInbox GET read routes, so even when an operator configures a secret, unauthen…

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00516 Published 2026-07-20 No fix listed CWE-862
Priority HIGH 77

Network-AI before 5.15.5 contains a path traversal vulnerability in InputSanitizer.sanitizePath() that allows attackers to escape the base directory using sibling-directory paths.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00537 Published 2026-11-02 Fixed in 5.15.5 CWE-22
Priority HIGH 77

Network-AI before 5.13.4 contains an improper cryptographic signature verification vulnerability in APSAdapter where the default local verifier accepts any non-empty string as valid.

CVSS 4.0HIGH 8.8 Network No auth No interaction EPSS 0.00258 Published 2026-07-20 Fixed in 5.13.4 CWE-347
Priority HIGH 76

Network-AI is a TypeScript/Node.js multi-agent orchestrator.

CVSS 3.1CRITICAL 9.9 Network Low privileges No interaction EPSS 0.00468 Published 2026-07-20 Fixed in 5.9.1 CWE-78
Priority HIGH 73

Network-AI from 5.13.4 before 5.15.5 contains a path traversal vulnerability in FileJobStore that allows attackers to read or delete arbitrary .json files by supplying traversal sequences in the job id.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00448 Published 2026-11-02 Fixed in 5.15.5 CWE-23
Priority HIGH 73

Network-AI versions before 5.15.1 contain a security matcher bypass vulnerability where SandboxPolicy evaluates raw command strings with quotes preserved while the executor tokenizes commands by stripping quotes before e…

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00654 Published 2026-08-13 Fixed in 5.15.1 CWE-436
Priority HIGH 73

Network-AI ClaudeHookBridge before 5.15.1 truncates the target string to 500 characters before evaluating denyPatterns, while Claude Code executes the full untruncated command.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00679 Published 2026-08-13 Fixed in 5.15.1 CWE-436
Priority HIGH 70

Network-AI from 5.14.0 before 5.15.5 contains a missing authentication vulnerability in the A2AServer class that allows unauthenticated attackers to access task operations when no secret is configured.

CVSS 4.0MEDIUM 6.9 Network No auth No interaction EPSS 0.0036 Published 2026-11-02 Fixed in 5.15.5 CWE-306
Priority MEDIUM 58

Network-AI is a TypeScript/Node.js multi-agent orchestrator.

CVSS 3.1MEDIUM 5.5 Local Low privileges No interaction EPSS 0.00188 Published 2026-07-20 Fixed in 5.12.2 CWE-22
Priority MEDIUM 57

Network-AI 5.0.0 before 5.15.2 contains a cross-site WebSocket hijacking vulnerability in DashboardServer that allows remote attackers to read live agent topology because handleUpgrade performs no Origin or token validat…

CVSS 4.0MEDIUM 5.3 Network No auth User interaction EPSS 0.00182 Published 2026-10-12 Fixed in 5.15.2 CWE-1385
Priority MEDIUM 45

Network-AI (npm network-ai) before 5.15.2 contains an origin validation error in McpSseServer._handleRequest in lib/mcp-transport-sse.ts that reflects localhost Origins into Access-Control-Allow-Origin regardless of bind…

CVSS 4.0LOW 2.3 Network No auth User interaction EPSS 0.00143 Published 2026-10-12 Fixed in 5.15.2 CWE-346
Priority MEDIUM 40

Network-AI from 5.13.4 before 5.15.5 contains a path traversal vulnerability in AgentVCR that allows attackers controlling the cassette name to read or write arbitrary .json files.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00448 Published 2026-11-02 Fixed in 5.15.5 CWE-23
Priority LOW 34

Network-AI from 5.14.0 before 5.15.2 contains a security control bypass vulnerability in the ClaudeHookBridge PreToolUse hook, which matches deny patterns only against the first present candidate field.

CVSS 4.0HIGH 7.5 Local No auth No interaction EPSS 0.00135 Published 2026-10-12 Fixed in 5.15.2 CWE-436
Open these records in search →