OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, versions, and backend configurations.
CVSS 4.0HIGH 8.7·Network·No auth·No interaction·EPSS 0.00432·Published 2026-08-16·Fixed in 1.8.3CWE-497
OpenTofu versions before 1.11.4 contain a denial of service vulnerability in the tofu init command when processing maliciously-crafted .zip archives for provider or module packages.
CVSS 4.0LOW 2.3·Network·No auth·User interaction·EPSS 0.00283·Published 2026-08-16·Fixed in 1.11.4CWE-400