The package otp-generator before 3.0.0 are vulnerable to Insecure Randomness due to insecure generation of random one-time passwords, which may allow a brute-force attack.
CVSS 3.1CRITICAL 9.8·Network·No auth·No interaction·EPSS 0.00909·Published 2022-07-25·Fixed in 3.0.0CWE-330