Read the docs

pixelgrade

Records20All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high7CVSS 7.0–8.9

Exploited now

pixelgrade records in CISA KEV

No pixelgrade vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

20 records

Priority MEDIUM 58

The PixCodes WordPress plugin before 2.3.7 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Store…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00471 Published 2023-01-30 Fixed in 2.3.7
Priority MEDIUM 42

Improper Restriction of XML External Entity Reference vulnerability in pixelgrade Category Icon category-icon allows XML Entity Linking.This issue affects Category Icon: from n/a through <= 1.0.3.

CVSS 3.1CRITICAL 9.1 Network High privileges No interaction EPSS 0.00552 Published 2025-06-09 No fix listed CWE-611
Priority LOW 31

Missing Authorization vulnerability in pixelgrade PixProof pixproof allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects PixProof: from n/a through <= 2.0.1.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00538 Published 2024-12-16 No fix listed CWE-862
Priority LOW 29

The Nova Blocks by Pixelgrade plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'align' attribute of the 'wp:separator' Gutenberg block in all versions up to, and including, 2.1.7 due to insuffici…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00373 Published 2024-09-10 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pixelgrade Nova Blocks nova-blocks allows DOM-Based XSS.This issue affects Nova Blocks: from n/a through <= 2.1.9.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.0019 Published 2026-01-23 No fix listed CWE-79
Priority LOW 28

The Open Hours – Easy Opening Hours plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'open-hours-current-status' shortcode in all versions up to, and including, 1.0.9 due to insufficient…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00293 Published 2025-02-18 No fix listed CWE-79
Priority LOW 26

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pixelgrade Category Icon category-icon allows Stored XSS.This issue affects Category Icon: from n/a through <= 1.0.2.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00181 Published 2025-12-24 No fix listed CWE-79
Priority LOW 23

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in pixelgrade Category Icon category-icon allows Path Traversal.This issue affects Category Icon: from n/a through <= 1.0.1.

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.00569 Published 2025-04-03 No fix listed CWE-22
Open these records in search →