Priority MEDIUM 60
The Product Catalog Feed by PixelYourSite WordPress plugin before 2.1.1 does not sanitise and escape the page parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could b…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00458 · Published 2023-05-02 · Fixed in 2.1.1 CWE-79
Priority MEDIUM 60
The Product Catalog Feed by PixelYourSite WordPress plugin before 2.1.1 does not sanitise and escape the edit parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could b…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00519 · Published 2023-05-02 · Fixed in 2.1.1 CWE-79
Priority MEDIUM 50
The Boost plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.0.3 via deserialization of untrusted input in the STYXKEY-BOOST_USER_LOCATION cookie.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00573 · Published 2026-05-20 · No fix listed CWE-502
Priority LOW 39
The Boost plugin for WordPress is vulnerable to time-based SQL Injection via the 'current_url' and 'user_name' parameters in versions up to, and including, 2.0.3 due to insufficient escaping on the user supplied paramete…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00366 · Published 2026-05-20 · No fix listed CWE-89
Priority LOW 39
The PixelYourSite – Your smart PIXEL (TAG) & API Manager and the PixelYourSite PRO plugins for WordPress are vulnerable to Sensitive Information Exposure in all versions up to, and including, 9.7.1 and 10.4.2, respective…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0045 · Published 2024-09-04 · No fix listed CWE-287
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in PixelYourSite Product Catalog Feed by PixelYourSite.This issue affects Product Catalog Feed by PixelYourSite: from n/a through 2.1.1.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00249 · Published 2023-12-17 · No fix listed CWE-352
Priority LOW 37
The Cost of Goods by PixelYourSite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'csvdata[0][cost_of_goods_value]' parameter in versions up to, and including, 1.2.12 due to insufficient input…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00255 · Published 2026-05-20 · No fix listed CWE-79
Priority LOW 33
Shop manager PHP Object Injection in Product Catalog Feed by PixelYourSite <= 3.1.4 versions.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.003 · Published 2026-10-29 · No fix listed CWE-502
Priority LOW 32
The PixelYourSite Pro – Your smart PIXEL (TAG) Manager plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 12.5.0.1 via the scan_video.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00577 · Published 2026-05-02 · No fix listed CWE-918
Priority LOW 32
The PixelYourSite PRO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pysTrafficSource' parameter and the 'pys_landing_page' parameter in all versions up to, and including, 12.4.0.2 due to insu…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00318 · Published 2026-02-13 · No fix listed CWE-79
Priority LOW 32
The PixelYourSite – Your smart PIXEL (TAG) & API Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pysTrafficSource' parameter and the 'pys_landing_page' parameter in all versions up to,…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.0034 · Published 2026-02-13 · No fix listed CWE-79
Priority LOW 31
The PixelYourSite – Your smart PIXEL (TAG) & API Manager plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.2.1 via the getWooPurchaseEventParams.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00576 · Published 2026-08-01 · Fixed in 12.6.1 CWE-200
Priority LOW 31
The EDD Product Catalog Feed by PixelYourSite plugin for WordPress is vulnerable to unauthorized modification of data that can lead to a denial of service due to a missing capability check on the wpeddpcf_delete_feed fun…
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00352 · Published 2026-09-08 · No fix listed CWE-862
Priority LOW 30
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PixelYourSite PixelYourSite – Your smart PIXEL (TAG) Manager pixelyoursite allows Stored XSS.This issue affects PixelY…
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00174 · Published 2026-02-20 · No fix listed CWE-79
Priority LOW 30
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00428 · Published 2025-12-29 · No fix listed CWE-200
Priority LOW 28
Subscriber Cross Site Scripting (XSS) in PixelYourSite – Your smart PIXEL (TAG) Manager <= 11.4.1 versions.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00224 · Published 2026-09-23 · No fix listed CWE-79
Priority LOW 28
PixelYourSite - Your smart PIXEL (TAG) and API Manager 10.1.1.1 was found to be vulnerable.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00385 · Published 2025-02-28 · No fix listed CWE-502
Priority LOW 26
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in PixelYourSite PixelYourSite – Your smart PIXEL (TAG) Manager allows Stored XSS.This issue affects PixelYourSite…
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.0026 · Published 2024-07-21 · No fix listed CWE-79
Priority LOW 26
Cross-site scripting vulnerability in PixelYourSite plugin prior to version 5.3.0 for WordPress allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00724 · Published 2018-05-14 · No fix listed CWE-79
Priority LOW 24
Cross-Site Request Forgery (CSRF) vulnerability in PixelYourSite PixelYourSite – Your smart PIXEL (TAG) Manager pixelyoursite allows Cross Site Request Forgery.This issue affects PixelYourSite – Your smart PIXEL (TAG) Ma…
CVSS 3.1MEDIUM 5.4· Network · No auth · User interaction · EPSS 0.00183 · Published 2025-01-07 · No fix listed CWE-352
Priority LOW 23
The PixelYourSite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 9.3.6 (9.6.1 in the Pro version) due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00516 · Published 2023-06-09 · No fix listed CWE-79
Priority LOW 20
Cross-Site Request Forgery (CSRF) vulnerability in PixelYourSite PixelYourSite – Your smart PIXEL (TAG) Manager plugin <= 9.3.0 versions.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00231 · Published 2023-03-13 · No fix listed CWE-352
Priority LOW 19
The PixelYourSite – Your smart PIXEL (TAG) & API Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 11.1.2.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00162 · Published 2025-10-22 · No fix listed CWE-352