Read the docs

PostgreSQL

Records229All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical15CVSS 9.0–10.0
CVSS high101CVSS 7.0–8.9

Exploited now

PostgreSQL records in CISA KEV

No PostgreSQL vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

229 records

Priority HIGH 82

pgjdbc, the PostgreSQL JDBC Driver, allows attacker to inject SQL if using PreferQueryMode=SIMPLE.

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.0481 Published 2024-02-19 Partial fix · 42.7.2, 42.6.1 +4 CWE-89
Priority HIGH 77

In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and users in the 'pg_execute_server_program' group to execute arbitrary code in the context of the database's operating system user.

CVSS 3.0HIGH 7.2 Network High privileges No interaction EPSS 0.91655 Published 2019-04-01 No fix listed CWE-78
TI-2017-05187 CVE-2017-7546 · GHSA-cj69-7h9j-r3j5

Improper authentication in postgresql

Priority HIGH 77

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to database accounts with an empty password.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.61566 Published 2017-08-16 Partial fix · 9.2.22, 9.3.18 +3 CWE-287
TI-2020-15711 CVE-2020-25695 · GHSA-xgxp-9x8p-gcw4

SQL injection in postgresql

Priority HIGH 68

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.4644 Published 2020-11-16 Partial fix CWE-89
Priority MEDIUM 61

Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, and 9.0.x before 9.0.13 allows remote attackers to cause a denial of service (file corruption), and allows remote authenticated users…

CVSS 2.0MEDIUM 6.5 Network Low privileges Interaction — EPSS 0.54312 Published 2013-04-04 Partial fix CWE-94
Priority MEDIUM 57

pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.4 through 42.7.13 pads a value that is shorter than its declared length with bytes left in its send buffer instead of zeros, and the server stores those bytes as part of…

CVSS 3.1MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00203 Published 2026-10-07 No fix listed CWE-201
TI-2022-01423 CVE-2022-1552 · GHSA-3f3c-74mp-823m

SQL injection in postgresql

Priority MEDIUM 55

A flaw was found in PostgreSQL.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.16981 Published 2022-08-31 Partial fix CWE-459
Priority MEDIUM 53

pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.4 and 42.7.5 can send the previous contents of the GSS send buffer in place of the first part of a value on a connection with GSS encryption (gssEncMode=prefer or require…

CVSS 3.1MEDIUM 4.2 Network Low privileges No interaction EPSS 0.00144 Published 2026-10-07 Fixed in 42.7.6 CWE-201
TI-2018-00978 CVE-2018-1058 · GHSA-wj3f-f94q-2r98

Improper input validation in postgresql

Priority MEDIUM 53

A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.13098 Published 2018-03-02 Partial fix CWE-20
Priority MEDIUM 52

postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.03826 Published 2018-05-10 Partial fix CWE-732
TI-2018-12060 CVE-2018-16850 · GHSA-h6p9-49w4-8mm8

SQL injection in postgresql

Priority MEDIUM 50

postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ...

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0515 Published 2018-11-13 Fixed CWE-89
TI-2015-02798 CVE-2015-3166 · GHSA-65w5-rcgr-gxgj

Memory corruption in PostgreSQL

Priority MEDIUM 50

The snprintf implementation in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 does not properly handle system-call errors, which allows attackers to obtain…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.04611 Published 2019-11-20 Partial fix · 9.0.20, 9.1.16 +2 CWE-119
TI-2015-00214 CVE-2015-0244 · GHSA-xvhg-pwg9-qp4r

SQL injection in PostgreSQL

Priority MEDIUM 49

PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 does not properly handle errors while reading a protocol message, which allows remote attackers to conduct SQ…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.04363 Published 2020-01-27 Partial fix · 9.0.19, 9.1.15 +3 CWE-89
Priority MEDIUM 47

Incorrect control of environment variables in PostgreSQL PL/Perl allows an unprivileged database user to change sensitive process environment variables (e.g.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04393 Published 2024-11-14 Partial fix · 17.1, 16.5 +4 CWE-15
Priority MEDIUM 47

A flaw was found in PostgreSQL that allows authenticated database users to execute arbitrary code through missing overflow checks during SQL array value modification.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04322 Published 2023-12-10 Partial fix · 4.2.4-6, 4.2.4-7 +29 CWE-190
Priority MEDIUM 47

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by the foreign server o…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.05581 Published 2017-08-16 Partial fix · 9.2.22, 9.3.18 +3 CWE-522
Priority MEDIUM 47

PostgreSQL, possibly 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x before 9.0.13, 8.4.x before 8.4.17, and 8.3.x before 8.3.23 incorrectly provides the superuser password to scripts related to "graphical installers for L…

CVSS 2.0HIGH 10.0 Network No auth Interaction — EPSS 0.02206 Published 2013-04-04 No fix listed CWE-264
TI-2019-07531 CVE-2019-10211 · GHSA-86r9-2cjw-549v

Code injection in postgresql

Priority MEDIUM 46

Postgresql Windows installer before versions 11.5, 10.10, 9.6.15, 9.5.19, 9.4.24 is vulnerable via bundled OpenSSL executing code from unprotected directory.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01815 Published 2019-10-29 No fix listed CWE-94
Load more
Open these records in search →