Priority CRITICAL 100KEV
A command injection vulnerability has been reported to affect QTS and QuTS hero.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.33987 · Published 2021-04-17 · Fixed in 4.5.2.1566 Build 20210202, 4.5.1.1495 Build 20201123 +5 CWE-77
Priority CRITICAL 100KEV
This improper input validation vulnerability allows remote attackers to inject arbitrary code to the system.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.14367 · Published 2019-12-05 · No fix listed CWE-20
Priority CRITICAL 100KEV
If exploited, this command injection vulnerability could allow remote attackers to run arbitrary commands.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.3016 · Published 2020-10-28 · Fixed in 4.4.2.1231, 4.4.1.1201 +4 CWE-20
Priority CRITICAL 100KEV
GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed function definitions in the values of environment variables, which allows remote attackers to write to files or possibly have unknown oth…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.9994 · Published 2014-09-25 · Fixed CWE-78
Priority CRITICAL 100KEV
GNU Bash through 4.3 processes trailing strings after function definitions in the values of environment variables, which allows remote attackers to execute arbitrary code via a crafted environment, as demonstrated by vec…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.99999 · Published 2014-09-24 · Fixed CWE-78
Priority CRITICAL 94KEV
If exploited, this cross-site scripting vulnerability could allow remote attackers to inject malicious code.
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.22682 · Published 2020-10-28 · Fixed in 4.4.2.1270, 4.4.1.1261 +4 CWE-79
Priority CRITICAL 86KEV
If exploited, this cross-site scripting vulnerability could allow remote attackers to inject malicious code.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.30527 · Published 2020-10-28 · Fixed in 4.4.2.1231, 4.4.1.1201 +4 CWE-79
Priority HIGH 79
An OS command injection vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1HIGH 8.3· Network · No auth · No interaction · EPSS 0.8992 · Published 2024-02-13 · Fixed in 5.1.5.2645 build 20240116, 4.x +3 CWE-77
Priority HIGH 78
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and obtain sensitive information via unspecified vectors.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.66146 · Published 2017-03-23 · No fix listed CWE-78
Priority HIGH 75
QNAP QTS before 4.2.4 Build 20170313 allows attackers to execute arbitrary commands via unspecified vectors.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.56847 · Published 2017-03-23 · No fix listed CWE-78
Priority HIGH 73
A link following vulnerability has been reported to affect several QNAP operating system versions.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.23758 · Published 2024-12-06 · Fixed in 5.1.8.2823 build 20240712, 5.2.0.2802 build 20240620 +2 CWE-59
Priority HIGH 73
A buffer copy without checking size of input vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.3752 · Published 2024-05-21 · Fixed in 5.1.7.2770 build 20240520, h5.1.7.2770 build 20240520 CWE-120
Priority HIGH 70
An improper authentication vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.24365 · Published 2024-03-08 · Fixed in 5.1.3.2578 build 20231110, 4.5.4.2627 build 20231225 +3 CWE-287
Priority HIGH 67
An OS command injection vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.18363 · Published 2023-11-03 · Fixed in 5.0.1.2376 build 20230421, 4.5.4.2374 build 20230416 +3 CWE-78
Priority HIGH 65
A path traversal vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1HIGH 8.7· Network · No auth · No interaction · EPSS 0.39663 · Published 2024-04-26 · Fixed in 5.1.4.2596 build 20231128, 4.5.4.2627 build 20231225 +3 CWE-22
Priority MEDIUM 64
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.26854 · Published 2017-03-23 · No fix listed CWE-78
Priority MEDIUM 63
A path traversal vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1HIGH 8.7· Network · No auth · No interaction · EPSS 0.34818 · Published 2024-04-26 · Fixed in 5.1.4.2596 build 20231128, 4.5.4.2627 build 20231225 +3 CWE-22
Priority MEDIUM 59
QNAP has patched a remote code execution vulnerability affecting the QTS Media Library in all versions prior to QTS 4.2.6 build 20170905 and QTS 4.3.3.0299 build 20170901.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.16678 · Published 2017-09-14 · No fix listed
Priority MEDIUM 58
A path traversal vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1MEDIUM 5.5· Network · High privileges · No interaction · EPSS 0.00454 · Published 2024-02-02 · Fixed in 5.1.5.2645 build 20240116, h5.1.5.2647 build 20240118 +1 CWE-22
Priority MEDIUM 58
An OS command injection vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.1415 · Published 2023-11-03 · Fixed in 2.1.2 ( 2023/05/04 ), 1.4.8 ( 2023/05/05 ) +7 CWE-77
Priority MEDIUM 54
A vulnerability has been reported to affect QNAP device running QuTS hero, QTS.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02663 · Published 2023-01-30 · Fixed in h5.0.1.2248 build 20221215, 5.0.1.2234 build 20221201 CWE-89
Priority MEDIUM 53
An OS command injection vulnerability has been reported to affect several QNAP operating system versions.
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.02315 · Published 2024-04-26 · Fixed in 5.1.3.2578 build 20231110, 4.5.4.2627 build 20231225 +3 CWE-77
Priority MEDIUM 49
A link following vulnerability has been reported to affect several QNAP operating system versions.
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.00702 · Published 2026-02-11 · Fixed in 5.2.8.3350 build 20251216, h5.3.2.3354 build 20251225 +1 CWE-59
Priority MEDIUM 49
A buffer overflow vulnerability in password function in QNAP QTS version 4.2.6 build 20171026, 4.3.3.0378 build 20171117, 4.3.4.0387 (Beta 2) build 20171116 and earlier could allow remote attackers to execute arbitrary c…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04439 · Published 2017-12-21 · No fix listed CWE-119
Priority MEDIUM 49
This command injection vulnerability in QTS allows attackers to run arbitrary commands in the compromised application.
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.03338 · Published 2017-06-15 · No fix listed CWE-77
Load more