Priority MEDIUM 43
Versions of Nexpose prior to 6.4.66 fail to adequately validate the source of HTTP requests intended for the Automated Actions administrative web application, and are susceptible to a cross-site request forgery (CSRF) at…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.02746 · Published 2017-12-14 · No fix listed CWE-352
Priority MEDIUM 42
Rapid7 Nexpose versions 6.6.186 and below suffer from a forced browsing vulnerability.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00446 · Published 2023-03-30 · No fix listed CWE-425
Priority MEDIUM 41
Rapid7 Nexpose versions 6.6.93 and earlier are susceptible to an SQL Injection vulnerability, whereby valid search operators are not defined.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01231 · Published 2022-03-17 · Fixed in 6.6.93 CWE-89
Priority MEDIUM 40
A Cross-Site Request Forgery (CSRF) vulnerability was found in Rapid7 Nexpose InsightVM Security Console versions 6.5.0 through 6.5.68.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.0089 · Published 2019-07-03 · No fix listed CWE-352
Priority LOW 39
Rapid7 Nexpose versions 6.5.50 and prior suffer from insufficient session expiration when an administrator performs a security relevant edit on an existing, logged on user.
CVSS 3.1HIGH 8.7· Network · Low privileges · User interaction · EPSS 0.00835 · Published 2019-08-21 · No fix listed CWE-613
Priority LOW 38
A SQL Injection issue in Rapid7 Nexpose version prior to 6.6.49 that may have allowed an authenticated user with a low permission level to access resources & make changes they should not have been able to access.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01137 · Published 2020-10-14 · Fixed in 6.6.49 CWE-89
Priority LOW 37
The default SSH configuration in Rapid7 Nexpose hardware appliances shipped before June 2017 does not specify desired algorithms for key exchange and other important functions.
CVSS 3.0HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00507 · Published 2017-06-06 · No fix listed CWE-327
Priority LOW 35
In Rapid7 Nexpose installer versions prior to 6.6.40, the Nexpose installer calls an executable which can be placed in the appropriate directory by an attacker with access to the local machine.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.00676 · Published 2020-09-03 · Fixed in 6.6.40 CWE-94
Priority LOW 35
All editions of Rapid7 Nexpose installers prior to version 6.4.24 contain a DLL preloading vulnerability, wherein it is possible for the installer to load a malicious DLL located in the current working directory of the i…
CVSS 3.0HIGH 7.8· Local · No auth · User interaction · EPSS 0.00772 · Published 2017-03-02 · No fix listed CWE-426
Priority LOW 35
The Java keystore in all versions and editions of Rapid7 Nexpose prior to 6.4.50 is encrypted with a static password of 'r@p1d7k3y5t0r3' which is not modifiable by the user.
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01489 · Published 2017-03-02 · No fix listed CWE-798
Priority LOW 34
Cross-site request forgery (CSRF) vulnerability in Rapid7 Nexpose Security Console before 5.5.4 allows remote attackers to hijack the authentication of unspecified victims for requests that delete scan data and sites via…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02306 · Published 2014-02-04 · No fix listed CWE-352
Priority LOW 30
Rapid7 Nexpose installer version prior to 6.6.40 contains an Unquoted Search Path which may allow an attacker on the local machine to insert an arbitrary file into the executable path.
CVSS 3.1MEDIUM 6.8· Physical · High privileges · User interaction · EPSS 0.00288 · Published 2020-09-03 · Fixed in 6.6.40 CWE-428
Priority LOW 30
Rapid7 Nexpose before 5.5.4 contains a session hijacking vulnerability which allows remote attackers to capture a user's session and gain unauthorized access.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01205 · Published 2020-01-25 · No fix listed CWE-79
Priority LOW 29
Rapid7 Nexpose and InsightVM versions prior to 6.6.172 failed to reliably validate the authenticity of update contents.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00323 · Published 2022-12-07 · No fix listed CWE-494
Priority LOW 28
Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00427 · Published 2022-03-17 · No fix listed CWE-79
Priority LOW 28
Rapid7 Nexpose is vulnerable to a non-persistent cross-site scripting vulnerability affecting the Security Console's Filtered Asset Search feature.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00581 · Published 2021-06-16 · Fixed in 6.6.81 CWE-79
Priority LOW 25
Rapid7 Nexpose version 6.6.95 and earlier allows authenticated users of the Security Console to view and edit any ticket in the legacy ticketing feature, regardless of the assignment of the ticket.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.00474 · Published 2021-08-19 · No fix listed CWE-306
Priority LOW 25
Rapid7 Nexpose versions prior to 6.6.114 suffer from an information exposure issue whereby, when the user's session has ended due to inactivity, an attacker can use the inspect element browser feature to remove the login…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00539 · Published 2021-11-22 · No fix listed CWE-200
Priority LOW 25
In the Create Tags page of the Rapid7 Nexpose version 6.4.12 user interface, any authenticated user who has the capability to create tags can inject cross-site scripting (XSS) elements in the tag name field.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00645 · Published 2016-12-20 · No fix listed CWE-79
Priority LOW 24
Rapid7 Nexpose and InsightVM versions 6.6.82 through 6.6.177 fail to validate the certificate of the update server when downloading updates.
CVSS 3.1MEDIUM 5.3· Adjacent network · No auth · No interaction · EPSS 0.00295 · Published 2023-02-01 · Fixed in 6.6.178 CWE-295