The Smart Forms WordPress plugin before 2.6.94 does not have proper authorization in some actions, which could allow users with a role as low as a subscriber to call them and perform unauthorized actions
CVSS 3.1MEDIUM 6.5·Network·Low privileges·No interaction·EPSS 0.00534·Published 2024-04-15·Fixed in 2.6.94CWE-863
The Smart Forms WordPress plugin before 2.6.87 does not have authorisation in various AJAX actions, which could allow users with a role as low as subscriber to call them and perform unauthorised actions such as deleting…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.00217·Published 2024-02-27·Fixed in 2.6.87CWE-352
The Smart Forms WordPress plugin before 2.6.94 does not have CSRF checks in some places, which could allow attackers to make logged-in users perform unwanted actions via CSRF attacks, such as editing entries, and we cons…
CVSS 3.1MEDIUM 5.4·Network·Low privileges·User interaction·EPSS 0.00226·Published 2024-04-15·Fixed in 2.6.94CWE-352
Cross-site request forgery (CSRF) vulnerability in Smart Forms 2.6.15 and earlier allows remote attackers to hijack the authentication of administrators via a specially crafted page.
Missing Authorization vulnerability in EDGARROJAS Smart Forms smart-forms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Smart Forms: from n/a through <= 2.6.84.
The Smart Forms WordPress plugin before 2.6.71 does not have authorisation in its rednao_smart_forms_entries_list AJAX action, allowing any authenticated users, such as subscriber, to download arbitrary form's data, whic…
CVSS 3.1MEDIUM 6.5·Network·Low privileges·No interaction·EPSS 0.00988·Published 2022-03-07·Fixed in 2.6.71CWE-862
The Smart Forms WordPress plugin before 2.6.96 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 5.9·Network·High privileges·User interaction·EPSS 0.0047·Published 2024-04-29·Fixed in 2.6.96CWE-79