Powerlevel10k through 1.20.0 contains an insecure download vulnerability in the gitstatus/install script that disables TLS certificate verification with curl -k and skips integrity checks when no SHA-256 utility exists.
Powerlevel10k before 1.20.19 contains an insecure temporary directory vulnerability in the bundled gitstatus/install script that reuses attacker-creatable directories when mktemp fails.
CVSS 4.0MEDIUM 5.4·Local·Low privileges·User interaction·EPSS 0.00115·Published 2026-11-04·Fixed in 1.20.19CWE-377
Powerlevel10k before 1.20.19 contains a symlink following vulnerability in _p9k_dump_instant_prompt that allows local attackers to overwrite victim-writable files via a predictable temporary path.
CVSS 4.0MEDIUM 4.1·Local·Low privileges·User interaction·EPSS 0.0012·Published 2026-11-04·Fixed in 1.20.19CWE-59