Read the docs

wproyal

Records99All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high18CVSS 7.0–8.9

Exploited now

wproyal records in CISA KEV

No wproyal vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

99 records

Priority HIGH 72

The Royal Elementor Addons and Templates WordPress plugin before 1.3.81 does not ensure that users accessing posts via an AJAX action (and REST endpoint, currently disabled in the plugin) have the right to do so, allowin…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0071 Published 2024-01-16 Fixed in 1.3.81
Priority MEDIUM 53

The Royal Elementor Addons WordPress plugin before 1.3.56 does not have authorisation and CSRF checks when creating a template, and does not ensure that the post created is a template.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00265 Published 2023-01-09 Fixed in 1.3.56 CWE-352
Priority MEDIUM 50

The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to limited file uploads due to missing file type validation in the 'file_validity' function in all versions up to, and including, 1.3.94.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01137 Published 2024-05-02 No fix listed CWE-434
Priority MEDIUM 48

The Royal Elementor Addons WordPress plugin before 1.3.56 does not have authorization and CSRF checks when deleting a template and does not ensure that the post to be deleted is a template.

CVSS 3.1LOW 3.1 Network Low privileges No interaction EPSS 0.00254 Published 2023-01-09 Fixed in 1.3.56 CWE-352
Priority MEDIUM 41

Inclusion of Functionality from Untrusted Control Sphere vulnerability in WP Royal Royal Elementor Addons royal-elementor-addons allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Royal El…

CVSS 3.1HIGH 8.2 Network No auth No interaction EPSS 0.00266 Published 2026-03-05 No fix listed CWE-829
Priority LOW 39

Missing Authorization vulnerability in wproyal News Magazine X news-magazine-x allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects News Magazine X: from n/a through <= 1.2.50.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00289 Published 2026-03-25 No fix listed CWE-862
Priority LOW 36

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in wproyal News Magazine X news-magazine-x allows PHP Local File Inclusion.This issue affects News Mag…

CVSS 3.1HIGH 7.5 Network No auth User interaction EPSS 0.00611 Published 2025-08-14 No fix listed CWE-98
Priority LOW 36

The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `widgetGrid`, `widgetCountDown`, and `widgetInstagramFeed` methods in all versions up to, and including,…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00291 Published 2025-04-12 No fix listed CWE-79
Priority LOW 33

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows Code Injection.This issue affects Royal Elementor Addons: f…

CVSS 3.1HIGH 7.6 Network Low privileges No interaction EPSS 0.00275 Published 2026-10-22 No fix listed CWE-470
Priority LOW 32

Improper Restriction of XML External Entity Reference vulnerability in WP Royal Royal Elementor Addons royal-elementor-addons allows XML Injection.This issue affects Royal Elementor Addons: from n/a through <= 1.3.980.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00549 Published 2024-10-28 No fix listed CWE-611
Priority LOW 31

The Royal Addons for Elementor – Addons and Templates Kit for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.7.1066 via the 'wpr_keyword' parameter.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00561 Published 2026-09-12 No fix listed CWE-200
Priority LOW 31

The Royal Addons for Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `wpr_update_form_action_meta` AJAX action in all versions up to, and includi…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00501 Published 2026-05-02 No fix listed CWE-862
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Royal Royal Elementor Addons royal-elementor-addons allows Reflected XSS.This issue affects Royal Elementor Addons:…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00289 Published 2024-12-31 No fix listed CWE-79
Load more
Open these records in search →