rust-base64 version <= 0.5.1 is vulnerable to a buffer overflow when calculating the size of a buffer to use when encoding base64 using the 'encode_config_buf' and 'encode_config' functions
CVSS 3.0CRITICAL 9.8·Network·No auth·No interaction·EPSS 0.01534·Published 2018-01-02·Fixed in 0.5.2CWE-119