Priority HIGH 67
The SEOPress WordPress plugin before 6.5.0.3 unserializes user input provided via the settings, which could allow high-privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.17686 · Published 2023-05-02 · Fixed in 6.5.0.3 CWE-502
Priority MEDIUM 55
The SEOPress WordPress plugin before 7.9 does not properly protect some of its REST API routes, which combined with another Object Injection vulnerability can allow unauthenticated attackers to unserialize malicious gadg…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03744 · Published 2024-07-09 · Fixed in 7.9 CWE-502
Priority MEDIUM 55
The SEOPress WordPress plugin before 7.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disall…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00402 · Published 2024-01-22 · Fixed in 7.3 CWE-79
Priority LOW 38
Missing Authorization vulnerability in Benjamin Denis SEOPress wp-seopress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SEOPress: from n/a through <= 8.1.1.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00293 · Published 2024-10-29 · No fix listed CWE-862
Priority LOW 38
Missing Authorization vulnerability in Benjamin Denis SEOPress wp-seopress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SEOPress: from n/a through <= 8.1.1.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00356 · Published 2024-10-29 · No fix listed CWE-862
Priority LOW 37
The SEOPress – AI SEO Plugin & On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Author Display Name in all versions up to, and including, 10.2 due to insufficient input sanitization and o…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00236 · Published 2026-10-03 · No fix listed CWE-79
Priority LOW 30
The SEOPress – On-site SEO plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and includ…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00452 · Published 2024-10-02 · No fix listed CWE-79
Priority LOW 29
The SEOPress – On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the image alt parameter in all versions up to, and including, 7.5.2.1 due to insufficient input sanitization and output esc…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00423 · Published 2024-04-09 · No fix listed CWE-20
Priority LOW 29
The SEOPress – On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's social image URL in all versions up to, and including, 7.9 due to insufficient input sanitization and output e…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00367 · Published 2024-06-20 · No fix listed CWE-79
Priority LOW 29
The SEOPress WordPress plugin is vulnerable to Stored Cross-Site-Scripting via the processPut function found in the ~/src/Actions/Api/TitleDescriptionMeta.php file which allows authenticated attackers to inject arbitrary…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00648 · Published 2021-08-16 · No fix listed CWE-79
Priority LOW 28
The SEOPress – AI SEO Plugin & On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'seopress_google_analytics_affiliate_tracking' and 'seopress_google_analytics_download_tracking' settin…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00201 · Published 2026-11-07 · No fix listed CWE-79
Priority LOW 28
The SEOPress – AI SEO Plugin & On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 10.3 due to insufficient input sanitizat…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00235 · Published 2026-10-31 · No fix listed CWE-79
Priority LOW 28
The SEOPress – On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the SEO title and description parameters as well as others in all versions up to, and including, 7.5.2.1 due to insufficien…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00257 · Published 2024-05-24 · No fix listed CWE-79
Priority LOW 27
The SEOPress WordPress plugin before 7.8 does not validate and escape one of its Post settings, which could allow contributor and above role to perform Open redirect attacks against any user viewing a malicious post
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00329 · Published 2024-06-24 · Fixed in 7.8 CWE-601
Priority LOW 24
Server-Side Request Forgery (SSRF) vulnerability in SEOPress allows Server Side Request Forgery.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00207 · Published 2026-09-03 · No fix listed CWE-918
Priority LOW 23
The SEOPress WordPress plugin before 7.8 does not sanitise and escape some of its Post settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks.
CVSS 3.1MEDIUM 5.0· Network · No auth · User interaction · EPSS 0.00337 · Published 2024-06-24 · Fixed in 7.8 CWE-79
Priority LOW 22
The SEOPress – AI SEO Plugin & On-site SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'seopress_google_analytics_matomo_id' parameter in all versions up to, and including, 10.2 due to insuf…
CVSS 3.1MEDIUM 4.9· Network · Low privileges · No interaction · EPSS 0.00241 · Published 2026-10-03 · No fix listed CWE-79