socat versions 1.8.0.0 through 1.8.1.1 contain a heap-based buffer overflow vulnerability that allows a malicious SOCKS5 proxy server to overwrite adjacent heap memory by exploiting a sign-extension flaw in the DOMAINNAM…
CVSS 4.0CRITICAL 9.2·Network·No auth·No interaction·EPSS 0.00314·Published 2026-06-25·Fixed in 1.8.1.2CWE-122
Format string vulnerability in the _msg function in error.c in socat 1.4.0.3 and earlier, when used as an HTTP proxy client and run with the -ly option, allows remote attackers or local users to execute arbitrary code vi…