Versions of the package spin.js before 3.0.0 are vulnerable to Cross-site Scripting (XSS) via the spin() function that allows a creation of more than 1 alert for each 'target' element.
CVSS 4.0MEDIUM 5.1·Network·No auth·User interaction·EPSS 0.00186·Published 2026-03-11·Fixed in 3.0.0CWE-79