Read the docs

strangerstudios

Records31All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high11CVSS 7.0–8.9

Exploited now

strangerstudios records in CISA KEV

No strangerstudios vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

31 records

Priority CRITICAL 92

The Paid Memberships Pro WordPress Plugin, version < 2.9.8, is affected by an unauthenticated SQL injection vulnerability in the 'code' parameter of the '/pmpro/v1/order' REST route.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.9246 Published 2023-01-20 Fixed in 2.9.8 CWE-89
Priority HIGH 83

The Paid Memberships Pro WordPress plugin before 2.6.7 does not escape the discount_code in one of its REST route (available to unauthenticated users) before using it in a SQL statement, leading to a SQL injection

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.81828 Published 2022-02-07 Fixed in 2.6.7 CWE-89
Priority HIGH 75

The Paid Memberships Pro WordPress plugin before 2.9.12 does not prevent subscribers from rendering shortcodes that concatenate attributes directly into an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.60452 Published 2023-03-20 Fixed in 2.9.12 CWE-89
Priority HIGH 70

The Paid Memberships Pro plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'pmpro_paypalexpress_session_vars_for_user_fields' function in versions up to, and inc…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.51254 Published 2023-11-18 No fix listed CWE-434
Priority MEDIUM 63

The Paid Memberships Pro WordPress plugin before 2.9.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to p…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.65006 Published 2023-02-13 Fixed in 2.9.9 CWE-79
Priority MEDIUM 62

The pmpro-member-directory WordPress plugin before 1.2.6 does not prevent users with at least the contributor role from leaking other users' sensitive information, including password hashes via an SQLi vector.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00523 Published 2024-07-30 Fixed in 1.2.6 CWE-202
Priority MEDIUM 58

The Memberlite Shortcodes WordPress plugin before 1.3.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00531 Published 2023-10-31 Fixed in 1.3.9 CWE-79
Priority MEDIUM 49

Authorization Bypass Through User-Controlled Key vulnerability in Paid Memberships Pro allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Paid Memberships Pro: from n/a through 3.0.4.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0067 Published 2024-11-01 No fix listed CWE-639
Priority MEDIUM 42

SQL injection vulnerability in the Paid Memberships Pro versions prior to 2.5.6 allows remote authenticated attackers to execute arbitrary SQL commands via unspecified vectors.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02044 Published 2021-03-18 Fixed in 2.5.6 CWE-89
Priority LOW 34

SQL injection vulnerability in the Paid Memberships versions prior to 2.3.3 allows attacker with administrator rights to execute arbitrary SQL commands via unspecified vectors.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.0119 Published 2020-05-20 Fixed in 2.3.3 CWE-89
Priority LOW 31

The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to unauthorized modification of membership levels created by the plugin due to an incorrectly imp…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00508 Published 2024-01-11 No fix listed CWE-862
Priority LOW 31

The Paid Memberships Pro WordPress plugin before 2.6.6 does not escape the s parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01654 Published 2021-12-27 Fixed in 2.6.6 CWE-79
Priority LOW 31

Multiple cross-site scripting (XSS) vulnerabilities in the Paid Memberships Pro (PMPro) plugin before 1.8.4.3 for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) s parameter to members…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.02065 Published 2017-10-23 No fix listed CWE-79
Priority LOW 29

The Memberlite Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's memberlite_accordion shortcode in all versions up to, and including, 1.3.9 due to insufficient input sanitizati…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00472 Published 2024-11-23 No fix listed CWE-79
Load more
Open these records in search →