Read the docs

theeventscalendar

Records7All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

theeventscalendar records in CISA KEV

No theeventscalendar vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

7 records

Priority MEDIUM 43

The Events Calendar Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 7.0.2 via deserialization of untrusted input from the 'filters' parameter in widgets.

CVSS 3.1CRITICAL 9.1 Network High privileges No interaction EPSS 0.00741 Published 2024-08-30 No fix listed CWE-502
Priority LOW 29

The EventCalendar WordPress plugin before 1.1.51 does not escape some user input before outputting it back in attributes, leading to Reflected Cross-SIte Scripting issues

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0081 Published 2022-01-17 Fixed in 1.1.51 CWE-79
Priority LOW 28

The The Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Event Calendar Link Widget through the html_tag attribute in all versions up to, and including, 6.9.0 due to insufficient…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00297 Published 2025-01-23 No fix listed CWE-79
Priority LOW 28

The Freemius SDK, as used by hundreds of WordPress plugin and theme developers, was vulnerable to Cross-Site Request Forgery and Information disclosure due to missing capability checks and nonce protection on the _get_de…

CVSS 3.1MEDIUM 6.3 Network Low privileges No interaction EPSS 0.00442 Published 2024-10-16 Fixed in 2.0.2, 1.9.8 +273 CWE-862
Priority LOW 24

Cross-site scripting (XSS) vulnerability in the Event Import page (import-eventbrite-events.php) in the Modern Tribe Eventbrite Tickets plugin before 3.10.2 for WordPress allows remote attackers to inject arbitrary web s…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02067 Published 2015-08-18 No fix listed CWE-79
Priority LOW 20

The EventCalendar WordPress plugin before 1.1.51 does not have proper authorisation and CSRF checks in the add_calendar_event AJAX actions, allowing users with a role as low as subscriber to create events

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00347 Published 2022-01-17 Fixed in 1.1.51 CWE-352
Open these records in search →