Priority HIGH 68
Thelia before 3.1.0 contains a stored cross-site scripting vulnerability in ForSomeCustomers::getSummary() that allows unauthenticated attackers to inject scripts via unescaped customer names.
CVSS 4.0HIGH 7.4· Network · No auth · User interaction · EPSS 0.00263 · Published 2026-10-31 · Fixed in 3.1.0 CWE-79
Priority MEDIUM 64
Thelia Back-office Default Twig Template before 1.1.1 contains a cross-site request forgery vulnerability in the /admin/product/combinations/update and /admin/product/default-price/update routes, which accept GET request…
CVSS 4.0MEDIUM 6.9· Network · No auth · User interaction · EPSS 0.00144 · Published 2026-11-01 · Fixed in 1.1.1 CWE-352
Priority MEDIUM 64
Thelia Page Module before 2.0.4 contains a cross-site request forgery vulnerability that allows remote attackers to delete page tags, documents and images by abusing back-office delete routes lacking CSRF tokens and perm…
CVSS 4.0HIGH 7.0· Network · No auth · User interaction · EPSS 0.00203 · Published 2026-10-31 · Fixed in 2.0.4 CWE-352
Priority MEDIUM 60
Thelia before 3.2.0 contains a cross-site request forgery vulnerability in the back office that allows attackers to forge administrative actions because per-session CSRF tokens leak via URL query strings.
CVSS 4.0MEDIUM 5.9· Network · No auth · User interaction · EPSS 0.0015 · Published 2026-10-31 · Fixed in 3.2.0, 1.2.0 CWE-352
Priority MEDIUM 45
Thelia before 3.1.2 and 3.2.x before 3.2.1 contains a CSV formula injection vulnerability that allows unauthenticated visitors to inject spreadsheet formulas by supplying crafted registration, checkout or newsletter fiel…
CVSS 4.0LOW 2.3· Network · No auth · User interaction · EPSS 0.00232 · Published 2026-10-12 · Fixed in 3.1.2, 3.2.1 CWE-1236
Priority MEDIUM 42
Thelia v2.6.1 contains path traversal and PHP code injection vulnerabilities in its translation editor that can be chained to achieve remote code execution.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01051 · Published 2026-10-12 · No fix listed CWE-434
Priority MEDIUM 40
Thelia before 3.1.2 and 3.2.x before 3.2.1 contains an unrestricted file upload vulnerability that allows authenticated back-office users to upload PHP files by appending a trailing space to filenames.
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.00441 · Published 2026-10-12 · Fixed in 3.1.2, 3.2.1 CWE-434
Priority MEDIUM 40
Thelia 3.0.0's back-office Email/Messages feature contains a server‑side template injection (SSTI) flaw that allows any authenticated user with the “Messages” permission to supply unsandboxed Twig templates, which are th…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0047 · Published 2026-10-12 · No fix listed CWE-1336
Priority LOW 35
In Thelia v2.6.0, the document upload endpoint properly blocks the upload of executable file types, but the document update endpoint does not perform the same validation.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.006 · Published 2026-10-12 · No fix listed CWE-434
Priority LOW 34
In Thelia v2.6.0, the store banner upload feature performs insufficient filetype validation that relies exclusively on client‑supplied MIME types.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00584 · Published 2026-10-12 · No fix listed CWE-434
Priority LOW 27
Thelia v2.6.0's Smarty templates (address.html and address-update.html) fail to properly escape double quotes in the “next” parameter, enabling reflected Cross‑Site Scripting (XSS) when an authenticated user visits the m…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00201 · Published 2026-10-12 · No fix listed CWE-79
Priority LOW 27
Thelia v2.6.0 contains an open redirect vulnerability in its address creation workflow.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00256 · Published 2026-10-12 · No fix listed CWE-601
Priority LOW 25
Thelia 2.6.1 contains an absolute path traversal vulnerability in its Smarty template handling that enables SSTI and remote code execution.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.00581 · Published 2026-10-12 · No fix listed CWE-1336
Priority LOW 25
Thelia 2.6.0 uses Smarty for email templates without properly restricting access to dangerous PHP functions.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.00517 · Published 2026-10-12 · No fix listed CWE-1336
Priority LOW 24
Thelia before 3.1.5 and 3.2.x before 3.2.4 contains a business logic vulnerability that allows authenticated customers to bypass coupon usage limits because usage is counted only when orders become paid.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00289 · Published 2026-10-19 · Fixed in 3.1.5, 3.2.4 CWE-837
Priority LOW 24
Thelia v2.6.0 permits authenticated administrators to upload and install modules via the ZIP upload function without validating or sandboxing embedded PHP code.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · No interaction · EPSS 0.00299 · Published 2026-10-12 · No fix listed CWE-434
Priority LOW 22
Thelia v2.6.0 is vulnerable to multiple stored XSS vulnerabilities within the administrative interface.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.0023 · Published 2026-10-12 · No fix listed CWE-79
Priority LOW 21
Thelia before 3.1.1 contains a stored cross-site scripting vulnerability that allows authenticated back-office administrators with store update permission to inject scripts by uploading unsanitized SVG logo_file or banne…
CVSS 4.0MEDIUM 4.6· Network · High privileges · User interaction · EPSS 0.00239 · Published 2026-11-01 · Fixed in 3.1.1, 1.1.1 CWE-79
Priority LOW 17
In Thelia v2.6.0, both the administrative login and forgotten password endpoints return different responses for invalid usernames and incorrect passwords, allowing unauthenticated attackers to enumerate valid administrat…
CVSS 3.1LOW 3.7· Network · No auth · No interaction · EPSS 0.00259 · Published 2026-10-12 · No fix listed CWE-204