Read the docs

uscnanbu

Records53All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high19CVSS 7.0–8.9

Exploited now

uscnanbu records in CISA KEV

No uscnanbu vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

53 records

Priority HIGH 73

The Welcart e-Commerce WordPress plugin before 2.9.5 does not validate files to be uploaded, as well as does not have authorisation and CSRF in an AJAX action handling such upload.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00479 Published 2023-12-04 Fixed in 2.9.5 CWE-434
Priority HIGH 73

The Welcart e-Commerce WordPress plugin before 2.8.6 does not validate user input before using it in file_exist() functions via various AJAX actions available to any authenticated users, which could allow users with a ro…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.0115 Published 2023-01-02 Fixed in 2.8.6
Priority HIGH 72

The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file, which could allow unauthenticated attacker to read arbitrary files on the server

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.03175 Published 2023-01-02 Fixed in 2.8.5
Priority MEDIUM 62

The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file via an AJAX action available to any authenticated users, which could allow users with a ro…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00852 Published 2023-01-02 Fixed in 2.8.5 CWE-552
TI-2023-05482 CVE-2023-5951 · GHSA-q765-37pc-9f2c

Welcart e-Commerce < 2.9.5 - Reflected XSS

Priority MEDIUM 60

The Welcart e-Commerce WordPress plugin before 2.9.5 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00471 Published 2023-12-04 Fixed in 2.9.5 CWE-79
Priority MEDIUM 58

The Welcart e-Commerce WordPress plugin before 2.8.9 does not validate and escapes one of its shortcode attributes, which could allow users with a role as low as a contributor to perform a Stored Cross-Site Scripting att…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00476 Published 2023-01-16 Fixed in 2.8.9
Priority MEDIUM 58

The Welcart e-Commerce WordPress plugin before 2.8.4 does not sanitise and escape some parameters, which could allow any authenticated users, such as subscriber to perform Stored Cross-Site Scripting attacks

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00491 Published 2022-12-12 Fixed in 2.8.4
Priority MEDIUM 45

The Welcart e-Commerce WordPress plugin before 2.9.5 unserializes user input from cookies, which could allow unautehtniacted users to perform PHP Object Injection when a suitable gadget is present on the blog

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01253 Published 2023-12-04 Fixed in 2.9.5
Priority MEDIUM 42

The Welcart e-Commerce plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.12.1 via deserialization of untrusted input in the Telecom EDY payment callback (usces_action_acti…

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.01089 Published 2026-09-05 No fix listed CWE-502
Priority MEDIUM 42

SQL injection vulnerability in Order Data Edit page of Welcart e-Commerce versions 2.7 to 2.8.21 allows a user with editor (without setting authority) or higher privilege to perform unintended database operations.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01192 Published 2023-09-26 No fix listed CWE-89
TI-2024-28385 CVE-2024-42404 · GHSA-f7pg-xgpm-7pv6

SQL injection in uscnanbu Welcart e-Commerce

Priority MEDIUM 41

SQL injection vulnerability in Welcart e-Commerce prior to 2.11.2 allows an attacker who can login to the product to obtain or alter the information stored in the database.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00482 Published 2024-09-18 Fixed in 2.11.2 CWE-89
Priority MEDIUM 40

The Welcart e-Commerce plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on the download_orderdetail_list(), change_orderlist(), and download_member_list() functions called via a…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00806 Published 2023-06-07 Fixed in 2.2.8 CWE-862
Priority LOW 38

The Welcart e-Commerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'custom_order' parameter in all versions up to, and including, 2.12.1 due to insufficient input sanitization and output esc…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00489 Published 2026-09-01 No fix listed CWE-79
Priority LOW 37

The Welcart e-Commerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Settlement Notification Parameters in all versions up to, and including, 2.12.2 due to insufficient input sanitization and outp…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00314 Published 2026-10-03 No fix listed CWE-79
Priority LOW 37

Multiple SQL injection vulnerabilities in the Welcart e-Commerce plugin 1.3.12 for WordPress allow remote attackers to execute arbitrary SQL commands via the (1) changeSort or (2) switch parameter in the usces_itemedit p…

CVSS 2.0HIGH 7.5 Network No auth Interaction — EPSS 0.02334 Published 2015-01-13 No fix listed CWE-89
Priority LOW 36

Welcart e-Commerce versions 2.7 to 2.8.21 allows a user with editor or higher privilege to upload an arbitrary file to an unauthorized directory.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01245 Published 2023-09-26 No fix listed CWE-434
Load more
Open these records in search →