Read the docs

Wpsocialrocket

Records5All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

Wpsocialrocket records in CISA KEV

No Wpsocialrocket vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

5 records

Priority MEDIUM 40

Cross-site request forgery (CSRF) vulnerability in Social Sharing Plugin versions prior to 1.2.10 allows remote attackers to hijack the authentication of administrators via unspecified vectors.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.01163 Published 2020-07-27 Fixed in 1.2.10 CWE-352
Priority LOW 30

The Social Rocket – Social Sharing Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the tweet_settings_save() and tweet_settings_update() functions in al…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00397 Published 2025-01-07 No fix listed CWE-862
Priority LOW 28

The Social Rocket – Social Sharing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'socialrocket-floating' shortcode in all versions up to, and including, 1.3.4 due to insufficie…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0032 Published 2025-01-07 No fix listed CWE-79
Priority LOW 23

The Social Rocket WordPress plugin before 1.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilte…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00602 Published 2022-10-10 Fixed in 1.3.3 CWE-79
Open these records in search →