Arbitrary filesystem write vulnerability in Yarn before 1.22.0 allows attackers to write to any path on the filesystem and potentially lead to arbitrary code execution by forcing the user to install a malicious package.
CVSS 3.1HIGH 7.5·Network·No auth·User interaction·EPSS 0.05159·Published 2020-02-24·Fixed in 1.22.0CWE-22
In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys.
CVSS 3.1HIGH 7.8·Local·No auth·User interaction·EPSS 0.01518·Published 2019-12-16·Fixed in 1.22.0CWE-59
Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.
CVSS 3.1HIGH 8.1·Network·No auth·No interaction·EPSS 0.00668·Published 2019-07-30·Fixed in 1.17.3CWE-311