The My Private Site plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.14 via the REST API.
The My Private Site WordPress plugin before 3.0.8 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
CVSS 3.1MEDIUM 4.3·Network·No auth·User interaction·EPSS 0.00429·Published 2022-06-27·Fixed in 3.0.8CWE-352