Buffer overflow in nslookupComplain function in BIND 4 allows remote attackers to gain root privileges.
Priority MEDIUM 53Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.
Summary
Buffer overflow in nslookupComplain function in BIND 4 allows remote attackers to gain root privileges.
Why it matters now
EPSS 0.07654 94th percentileScored 2026-11-07
Fix Fixed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:4.9.3:*:*:*:*:*:*:* | 4.9.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.5:*:*:*:*:*:*:* | 4.9.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.5:p1:*:*:*:*:*:* | 4.9.5 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.6:*:*:*:*:*:*:* | 4.9.6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.7:*:*:*:*:*:*:* | 4.9.7 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:4.9.3:*:*:*:*:*:*:* Versions 4.9.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.5:*:*:*:*:*:*:* Versions 4.9.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.5:p1:*:*:*:*:*:* Versions 4.9.5 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.6:*:*:*:*:*:*:* Versions 4.9.6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.7:*:*:*:*:*:*:* Versions 4.9.7 Vulnerable ·ISC
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Linux 5.2 | Fixed | RHSA-2001:007 |
| Red Hat Linux 6.2 | Fixed | RHSA-2001:007 |
| Red Hat Linux 7.0 | Fixed | RHSA-2001:007 |
Timeline
- 2026-10-02 Threatist record created from CVE-2001-0011
- 2026-10-03 Alias added: GHSA-vpmv-x387-37fq
References
Patch 1
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2001-0011 · CVE Program
- CVE-2001-0011 · NVD
- FIRST EPSS
- GHSA-vpmv-x387-37fq · GitHub Advisory Database · CC BY 4.0
- CVE-2001-0011 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences