Vulnerability in the MIT-SHM extension of the X server on Linux (XFree86) 4.2.1 and…
Priority LOW 22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.
Summary
Vulnerability in the MIT-SHM extension of the X server on Linux (XFree86) 4.2.1 and earlier allows local users to read and write arbitrary shared memory, possibly to cause a denial of service or gain privileges.
Why it matters now
EPSS 0.00427 37th percentileScored 2026-11-07
Fix Fixed Red Hat: 4 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:caldera:openlinux_server:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Caldera |
| cpe:2.3:a:caldera:openlinux_server:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | Caldera |
| cpe:2.3:a:caldera:openlinux_workstation:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Caldera |
| cpe:2.3:a:caldera:openlinux_workstation:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | Caldera |
- cpe:2.3:a:caldera:openlinux_server:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Caldera
- cpe:2.3:a:caldera:openlinux_server:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Caldera
- cpe:2.3:a:caldera:openlinux_workstation:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Caldera
- cpe:2.3:a:caldera:openlinux_workstation:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Caldera
Remediation
Red Hat 4 advisories
- RHSA-2003:066 Released 2003-06-25 · Red Hat rating Important: Updated XFree86 packages provide security and bug fixes
- Red Hat Linux 7.3
- RHSA-2003:064 Released 2003-06-25 · Red Hat rating Important: Updated XFree86 4.1.0 packages are available
- Red Hat Linux 7.1
- Red Hat Linux 7.2
- RHSA-2003:067 Released 2003-06-25 · Red Hat rating Important: Updated XFree86 packages provide security and bug fixes
- Red Hat Linux 8.0
Show 1 more Red Hat advisories
- RHSA-2003:065 Released 2003-06-25 · Red Hat rating ImportantXFree86 security update
- Red Hat Enterprise Linux AS (Advanced Server) version 2.1
- Red Hat Enterprise Linux ES version 2.1
- Red Hat Enterprise Linux WS version 2.1
- Red Hat Linux Advanced Workstation 2.1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AS (Advanced Server) version 2.1 | Fixed | RHSA-2003:065 |
| Red Hat Enterprise Linux ES version 2.1 | Fixed | RHSA-2003:065 |
| Red Hat Enterprise Linux WS version 2.1 | Fixed | RHSA-2003:065 |
| Red Hat Linux 7.1 | Fixed | RHSA-2003:064 |
| Red Hat Linux 7.2 | Fixed | RHSA-2003:064 |
| Red Hat Linux 7.3 | Fixed | RHSA-2003:066 |
| Red Hat Linux 8.0 | Fixed | RHSA-2003:067 |
| Red Hat Linux Advanced Workstation 2.1 | Fixed | RHSA-2003:065 |
Timeline
- 2026-10-02 Threatist record created from CVE-2002-0164
- 2026-10-03 Alias added: GHSA-qmpx-29w7-4qjr
References
More Caldera Openlinux Server vulnerabilities
- TI-2001-00985 Squid before 2.3STABLE5 in HTTP accelerator mode does not enable access control lists… CVSS 2.0HIGH 7.5
- TI-2001-00936 docview before 1.0-15 allows remote attackers to execute arbitrary commands via shell… CVSS 2.0HIGH 7.5
- TI-2002-00004 Heap corruption vulnerability in the "at" program allows local users to execute arbitrary… CVSS 2.0HIGH 7.2
- TI-2002-00811 Preboot eXecution Environment (PXE) server allows remote attackers to cause a denial of… CVSS 2.0MEDIUM 5.0
- TI-2001-00814 Linux kernel 2.0, 2.2 and 2.4 with syncookies enabled allows remote attackers to bypass… CVSS 2.0MEDIUM 5.0
- TI-2003-00615 Docview before 1.1-18 in Caldera OpenLinux 3.1.1, SCO Linux 4.0, OpenServer 5.0.7… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2002-0164 · CVE Program
- CVE-2002-0164 · NVD
- FIRST EPSS
- GHSA-qmpx-29w7-4qjr · GitHub Advisory Database · CC BY 4.0
- CVE-2002-0164 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences