Read the docs
TI-2002-00385 Aliases CVE-2002-0400GHSA-7h7w-5gqf-34vm

ISC BIND 9 before 9.2.1 allows remote attackers to cause a denial of service (shutdown)…

Priority LOW 38Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.

Summary

ISC BIND 9 before 9.2.1 allows remote attackers to cause a denial of service (shutdown) via a malformed DNS packet that triggers an error condition that is not properly handled when the rdataset parameter to the dns_message_findtype() function in message.c is not NULL, aka DoS_findtype.

Why it matters now

EPSS 0.14218 96th percentileScored 2026-11-07
Fix Fixed Red Hat: 2 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.0:*:*:*:*:*:*:*9.0VulnerableISC
cpe:2.3:a:isc:bind:9.1:*:*:*:*:*:*:*9.1VulnerableISC
cpe:2.3:a:isc:bind:9.1.1:*:*:*:*:*:*:*9.1.1VulnerableISC
cpe:2.3:a:isc:bind:9.1.2:*:*:*:*:*:*:*9.1.2VulnerableISC
cpe:2.3:a:isc:bind:9.1.3:*:*:*:*:*:*:*9.1.3VulnerableISC
cpe:2.3:a:isc:bind:9.2:*:*:*:*:*:*:*9.2VulnerableISC
  • cpe:2.3:a:isc:bind:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.1:*:*:*:*:*:*:* Versions 9.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.1.1:*:*:*:*:*:*:* Versions 9.1.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.1.2:*:*:*:*:*:*:* Versions 9.1.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.1.3:*:*:*:*:*:*:* Versions 9.1.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2:*:*:*:*:*:*:* Versions 9.2 Vulnerable ·ISC

Remediation

Red Hat 2 advisories

  • RHSA-2003:154 Released 2003-06-18 · Red Hat rating Important
    : : : Updated bind packages fix buffer overflow in resolver library
    • Red Hat Linux 7.1
  • RHSA-2002:119 Released 2002-07-30 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux AS (Advanced Server) version 2.1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AS (Advanced Server) version 2.1 Fixed RHSA-2002:119
Red Hat Linux 7.1Fixed RHSA-2002:105
Red Hat Linux 7.2Fixed RHSA-2002:105
Red Hat Linux 7.3Fixed RHSA-2002:105

Timeline

  1. 2026-10-02 Threatist record created from CVE-2002-0400
  2. 2026-10-03 Alias added: GHSA-7h7w-5gqf-34vm

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources