The default servlet (org.apache.catalina.servlets.DefaultServlet) in Tomcat 4.0.4 and…
Priority MEDIUM 41CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
The default servlet (org.apache.catalina.servlets.DefaultServlet) in Tomcat 4.0.4 and 4.1.10 and earlier allows remote attackers to read source code for server files via a direct request to the servlet.
Why it matters now
EPSS 0.18648 97th percentileScored 2026-11-07
Fix Fixed org.apache.tomcat:tomcat (Maven): 4.0.5, 4.1.12Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.tomcat:tomcat (Maven) | 4.0.0 to before 4.0.5 | 4.0.5 | Patch available | GHSA-jxcv-v856-j5vg |
| — | org.apache.tomcat:tomcat (Maven) | 4.1.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-jxcv-v856-j5vg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.tomcat:tomcat (Maven) Vendor— Affected 4.0.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-jxcv-v856-j5vg
- org.apache.tomcat:tomcat (Maven) Vendor— Affected 4.1.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-jxcv-v856-j5vg
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.2.2:beta2:*:*:*:*:*:* | 3.2.2 beta2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.2.3:*:*:*:*:*:*:* | 3.2.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.2.4:*:*:*:*:*:*:* | 3.2.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.3:*:*:*:*:*:*:* | 3.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.2.2:beta2:*:*:*:*:*:* Versions 3.2.2 beta2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.2.4:*:*:*:*:*:*:* Versions 3.2.4 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Apache
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* | 4.0.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* | 4.0.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.3:beta:*:*:*:*:*:* | 4.1.3 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.9:beta:*:*:*:*:*:* | 4.1.9 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.10:*:*:*:*:*:*:* | 4.1.10 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.3:beta:*:*:*:*:*:* Versions 4.1.3 beta Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.9:beta:*:*:*:*:*:* Versions 4.1.9 beta Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.10:*:*:*:*:*:*:* Versions 4.1.10 Vulnerable ·Apache
Remediation
- Fix · GHSA-jxcv-v856-j5vg org.apache.tomcat:tomcat (Maven) Fixed in 4.0.5 Advisory →
- Fix · GHSA-jxcv-v856-j5vg org.apache.tomcat:tomcat (Maven) Fixed in 4.1.12 Advisory →
Red Hat 2 advisories
- RHSA-2002:217 Released 2002-11-08 · Red Hat rating Importanttomcat security update for Stronghold
- Red Hat Stronghold 4
- RHSA-2002:218 Released 2002-11-05 · Red Hat rating Importanttomcat security update for Stronghold
- Stronghold 4 for Red Hat Enterprise Linux
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Stronghold 4 | Fixed | RHSA-2002:217 |
| Stronghold 4 for Red Hat Enterprise Linux | Fixed | RHSA-2002:218 |
Timeline
- 2026-10-02 Threatist record created from CVE-2002-1148
- 2026-10-03 Alias added: GHSA-jxcv-v856-j5vg
References
Advisory 5
Other 13
- 20020924 JSP source code exposure in Tomcat 4.x
- [tomcat-dev] 20190319 svn commit: r1855831 [21/30] - in /tomcat/site/trunk: ./ docs/ xdocs/
- [tomcat-dev] 20190325 svn commit: r1856174 [19/29] - in /tomcat/site/trunk: docs/ xdocs/ xdocs/stylesheets/
- [tomcat-dev] 20200213 svn commit: r1873980 [24/34] - /tomcat/site/trunk/docs/
- https://lists.apache.org/thread.html/29dc6c2b625789e70a9c4756b5a327e6547273ff8bde7e0327af48c5@<dev.tomcat.apache.org>
- https://lists.apache.org/thread.html/c62b0e3a7bf23342352a5810c640a94b6db69957c5c19db507004d74@<dev.tomcat.apache.org>
- https://lists.apache.org/thread.html/rb71997f506c6cc8b530dd845c084995a9878098846c7b4eacfae8db3@<dev.tomcat.apache.org>
- https://web.archive.org/web/20021027204137/http://www.iss.net/security_center/static/10175.php
- https://web.archive.org/web/20030113141130/http://online.securityfocus.com/advisories/4758
- https://web.archive.org/web/20030710185447/http://www.securityfocus.com/bid/5786
- https://web.archive.org/web/20040814165854/http://rhn.redhat.com/errata/RHSA-2002-217.html
- https://web.archive.org/web/20040817035804/http://rhn.redhat.com/errata/RHSA-2002-218.html
- https://web.archive.org/web/20070430075037/http://www.debian.org/security/2002/dsa-170
More Apache Tomcat vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2016-07192 Improper access control in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2017-09342 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2017-09340 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2026-26741 Apache Tomcat: Fix for CVE-2026-29146 allowed bypass of EncryptInterceptor KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2002-1148 · CVE Program
- CVE-2002-1148 · NVD
- FIRST EPSS
- GHSA-jxcv-v856-j5vg · GitHub Advisory Database · CC BY 4.0
- CVE-2002-1148 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences