Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default…
Priority MEDIUM 42CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
Why it matters now
EPSS 0.05855 93rd percentileScored 2026-11-07
Fix Fixed org.apache.tomcat:tomcat (Maven): 4.0.6Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.tomcat:tomcat (Maven) | before 4.0.6 | 4.0.6 | Patch available | GHSA-8v5p-2cpv-c2x6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.tomcat:tomcat (Maven) Vendor— Affected before 4.0.6 Fixed in 4.0.6 Patch available GHSA-8v5p-2cpv-c2x6
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* | 4.0.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* | 4.0.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.5:*:*:*:*:*:*:* | 4.0.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.3:beta:*:*:*:*:*:* | 4.1.3 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.9:beta:*:*:*:*:*:* | 4.1.9 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.1.10:*:*:*:*:*:*:* | 4.1.10 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.5:*:*:*:*:*:*:* Versions 4.0.5 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.3:beta:*:*:*:*:*:* Versions 4.1.3 beta Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.9:beta:*:*:*:*:*:* Versions 4.1.9 beta Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.1.10:*:*:*:*:*:*:* Versions 4.1.10 Vulnerable ·Apache
Remediation
- Fix · GHSA-8v5p-2cpv-c2x6 org.apache.tomcat:tomcat (Maven) Fixed in 4.0.6 Advisory →
Red Hat 2 advisories
- RHSA-2003:075 Released 2003-04-09 · Red Hat rating Importanttomcat security update for Stronghold
- Stronghold 4 for Red Hat Enterprise Linux
- RHSA-2003:082 Released 2003-03-03 · Red Hat rating Importantapache, openssl, php, tomcat security update for Stronghold
- Red Hat Stronghold 4
Vendor assessments
Red Hat
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Stronghold 4 | Fixed | RHSA-2003:082 |
| Stronghold 4 for Red Hat Enterprise Linux | Fixed | RHSA-2003:075 |
Timeline
- 2026-10-02 Threatist record created from CVE-2002-1394
- 2026-10-03 Alias added: GHSA-8v5p-2cpv-c2x6
References
Advisory 5
Other 12
- http://marc.info/?l=tomcat-dev&m=103417249325526&w=2
- http://issues.apache.org/bugzilla/show_bug.cgi?id=13365
- [tomcat-dev] 20190319 svn commit: r1855831 [21/30] - in /tomcat/site/trunk: ./ docs/ xdocs/
- [tomcat-dev] 20190325 svn commit: r1856174 [19/29] - in /tomcat/site/trunk: docs/ xdocs/ xdocs/stylesheets/
- [tomcat-dev] 20200213 svn commit: r1873980 [24/34] - /tomcat/site/trunk/docs/
- https://archive.apache.org/dist/tomcat/tomcat-4/archive/v4.0.6/README.html
- https://lists.apache.org/thread.html/29dc6c2b625789e70a9c4756b5a327e6547273ff8bde7e0327af48c5@<dev.tomcat.apache.org>
- https://lists.apache.org/thread.html/rb71997f506c6cc8b530dd845c084995a9878098846c7b4eacfae8db3@<dev.tomcat.apache.org>
- https://web.archive.org/web/20030412075128/http://rhn.redhat.com/errata/RHSA-2003-075.html
- https://web.archive.org/web/20030705143220/http://www.securityfocus.com/bid/6562
- https://web.archive.org/web/20041024213235/http://rhn.redhat.com/errata/RHSA-2003-082.html
- https://web.archive.org/web/20070430073829/http://www.debian.org/security/2003/dsa-225
More Apache Tomcat vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2016-07192 Improper access control in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2017-09342 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2017-09340 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2026-26741 Apache Tomcat: Fix for CVE-2026-29146 allowed bypass of EncryptInterceptor KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2002-1394 · CVE Program
- CVE-2002-1394 · NVD
- FIRST EPSS
- GHSA-8v5p-2cpv-c2x6 · GitHub Advisory Database · CC BY 4.0
- CVE-2002-1394 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences