Read the docs
TI-2002-01455 Aliases CVE-2002-1533GHSA-5mq8-h82p-wjf2

Cross-site scripting (XSS) vulnerability in Jetty JSP servlet engine allows remote…

Priority LOW 31CWE-80Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Partial · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.

Summary

Cross-site scripting (XSS) vulnerability in Jetty JSP servlet engine allows remote attackers to insert arbitrary HTML or script via an HTTP request to a .jsp file whose name contains the malicious script and some encoded linefeed characters (%0a).

Why it matters now

EPSS 0.02407 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.mortbay.jetty:jetty (Maven): 4.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.mortbay.jetty:jetty (Maven)before 4.1.14.1.1Patch availableGHSA-5mq8-h82p-wjf2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.mortbay.jetty:jetty (Maven) Vendor— Affected before 4.1.1 Fixed in 4.1.1 Patch available GHSA-5mq8-h82p-wjf2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jetty:jetty:4.1.0_rc4:*:*:*:*:*:*:*4.1.0_rc4Vulnerablejetty
  • cpe:2.3:a:jetty:jetty:4.1.0_rc4:*:*:*:*:*:*:* Versions 4.1.0_rc4 Vulnerable ·jetty

Remediation

  • Fix · GHSA-5mq8-h82p-wjf2 org.mortbay.jetty:jetty (Maven) Fixed in 4.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2002-1533
  2. 2026-10-03 Alias added: GHSA-5mq8-h82p-wjf2

References

  • TI-2006-02666 Directory traversal vulnerability in jetty 6.0.x (jetty6) beta16 allows remote attackers… CVSS 2.0MEDIUM 5.0
  • TI-2006-02667 jetty 6.0.x (jetty6) beta16 allows remote attackers to read arbitrary script source code… CVSS 2.0MEDIUM 5.0

Sources