Read the docs
TI-2002-01925 Aliases CVE-2002-2006GHSA-8g4f-fh7f-4fwh

The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows…

Priority MEDIUM 47Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Partial · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows remote attackers to obtain the installation path and other sensitive system information via the (1) SnoopServlet or (2) TroubleShooter example servlets.

Why it matters now

EPSS 0.30673 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.tomcat:tomcat (Maven): 4.1.0, 3.3a

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.tomcat:tomcat (Maven)4.0.0 to before 4.1.04.1.0Patch availableGHSA-8g4f-fh7f-4fwh
—org.apache.tomcat:tomcat (Maven)3.0 to before 3.3a3.3aPatch availableGHSA-8g4f-fh7f-4fwh
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.tomcat:tomcat (Maven) Vendor— Affected 4.0.0 to before 4.1.0 Fixed in 4.1.0 Patch available GHSA-8g4f-fh7f-4fwh
  • org.apache.tomcat:tomcat (Maven) Vendor— Affected 3.0 to before 3.3a Fixed in 3.3a Patch available GHSA-8g4f-fh7f-4fwh

CPE configurations NVD · 14

CPEVersionsRoleVendor
cpe:2.3:a:apache:tomcat:3.0:*:*:*:*:*:*:*3.0VulnerableApache
cpe:2.3:a:apache:tomcat:3.1:*:*:*:*:*:*:*3.1VulnerableApache
cpe:2.3:a:apache:tomcat:3.1.1:*:*:*:*:*:*:*3.1.1VulnerableApache
cpe:2.3:a:apache:tomcat:3.2:*:*:*:*:*:*:*3.2VulnerableApache
cpe:2.3:a:apache:tomcat:3.2.1:*:*:*:*:*:*:*3.2.1VulnerableApache
cpe:2.3:a:apache:tomcat:3.2.3:*:*:*:*:*:*:*3.2.3VulnerableApache
cpe:2.3:a:apache:tomcat:3.2.4:*:*:*:*:*:*:*3.2.4VulnerableApache
cpe:2.3:a:apache:tomcat:3.3:*:*:*:*:*:*:*3.3VulnerableApache
cpe:2.3:a:apache:tomcat:3.3.1:*:*:*:*:*:*:*3.3.1VulnerableApache
cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:*4.0.0VulnerableApache
  • cpe:2.3:a:apache:tomcat:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.2.4:*:*:*:*:*:*:* Versions 3.2.4 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
Show 4 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:*4.0.1VulnerableApache
cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:*4.0.2VulnerableApache
cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:*4.0.3VulnerableApache
cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:*4.1.0VulnerableApache
  • cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:tomcat:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-8g4f-fh7f-4fwh org.apache.tomcat:tomcat (Maven) Fixed in 4.1.0 Advisory →
  • Fix · GHSA-8g4f-fh7f-4fwh org.apache.tomcat:tomcat (Maven) Fixed in 3.3a Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2002-2006
  2. 2026-10-03 Alias added: GHSA-8g4f-fh7f-4fwh

References

  • TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
  • TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-07192 Improper access control in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-09342 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
  • TI-2017-09340 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
  • TI-2026-26741 Apache Tomcat: Fix for CVE-2026-29146 allowed bypass of EncryptInterceptor KEVCVSS 3.1HIGH 7.5
See all 273 →

Sources