BIND 4 and BIND 8, when resolving recursive DNS queries for arbitrary hosts, allows…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA.
Summary
BIND 4 and BIND 8, when resolving recursive DNS queries for arbitrary hosts, allows remote attackers to conduct DNS cache poisoning via a birthday attack that uses a large number of open queries for the same resource record (RR) combined with spoofed responses, which increases the possibility of successfully spoofing a response in a way that is more efficient than brute force methods.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 31
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:4.9:*:*:*:*:*:*:* | 4.9 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.2:*:*:*:*:*:*:* | 4.9.2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.3:*:*:*:*:*:*:* | 4.9.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.4:*:*:*:*:*:*:* | 4.9.4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.5:*:*:*:*:*:*:* | 4.9.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.5:p1:*:*:*:*:*:* | 4.9.5 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.6:*:*:*:*:*:*:* | 4.9.6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.7:*:*:*:*:*:*:* | 4.9.7 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.8:*:*:*:*:*:*:* | 4.9.8 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:4.9.9:*:*:*:*:*:*:* | 4.9.9 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:4.9:*:*:*:*:*:*:* Versions 4.9 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.2:*:*:*:*:*:*:* Versions 4.9.2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.3:*:*:*:*:*:*:* Versions 4.9.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.4:*:*:*:*:*:*:* Versions 4.9.4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.5:*:*:*:*:*:*:* Versions 4.9.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.5:p1:*:*:*:*:*:* Versions 4.9.5 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.6:*:*:*:*:*:*:* Versions 4.9.6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.7:*:*:*:*:*:*:* Versions 4.9.7 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.8:*:*:*:*:*:*:* Versions 4.9.8 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:4.9.9:*:*:*:*:*:*:* Versions 4.9.9 Vulnerable ·ISC
Show 21 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:4.9.10:*:*:*:*:*:*:* | 4.9.10 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2:*:*:*:*:*:*:* | 8.2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.1:*:*:*:*:*:*:* | 8.2.1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:*:*:*:*:*:*:* | 8.2.2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p1:*:*:*:*:*:* | 8.2.2 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p2:*:*:*:*:*:* | 8.2.2 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p3:*:*:*:*:*:* | 8.2.2 p3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p4:*:*:*:*:*:* | 8.2.2 p4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p5:*:*:*:*:*:* | 8.2.2 p5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p6:*:*:*:*:*:* | 8.2.2 p6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.2:p7:*:*:*:*:*:* | 8.2.2 p7 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.3:*:*:*:*:*:*:* | 8.2.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.4:*:*:*:*:*:*:* | 8.2.4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.5:*:*:*:*:*:*:* | 8.2.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.6:*:*:*:*:*:*:* | 8.2.6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.2.7:*:*:*:*:*:*:* | 8.2.7 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.3.0:*:*:*:*:*:*:* | 8.3.0 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.3.1:*:*:*:*:*:*:* | 8.3.1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.3.2:*:*:*:*:*:*:* | 8.3.2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.3.3:*:*:*:*:*:*:* | 8.3.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:8.3.4:*:*:*:*:*:*:* | 8.3.4 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:4.9.10:*:*:*:*:*:*:* Versions 4.9.10 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2:*:*:*:*:*:*:* Versions 8.2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.1:*:*:*:*:*:*:* Versions 8.2.1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:*:*:*:*:*:*:* Versions 8.2.2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p1:*:*:*:*:*:* Versions 8.2.2 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p2:*:*:*:*:*:* Versions 8.2.2 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p3:*:*:*:*:*:* Versions 8.2.2 p3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p4:*:*:*:*:*:* Versions 8.2.2 p4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p5:*:*:*:*:*:* Versions 8.2.2 p5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p6:*:*:*:*:*:* Versions 8.2.2 p6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.2:p7:*:*:*:*:*:* Versions 8.2.2 p7 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.3:*:*:*:*:*:*:* Versions 8.2.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.4:*:*:*:*:*:*:* Versions 8.2.4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.5:*:*:*:*:*:*:* Versions 8.2.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.6:*:*:*:*:*:*:* Versions 8.2.6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.2.7:*:*:*:*:*:*:* Versions 8.2.7 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.3.0:*:*:*:*:*:*:* Versions 8.3.0 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.3.1:*:*:*:*:*:*:* Versions 8.3.1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.3.2:*:*:*:*:*:*:* Versions 8.3.2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.3.3:*:*:*:*:*:*:* Versions 8.3.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:8.3.4:*:*:*:*:*:*:* Versions 8.3.4 Vulnerable ·ISC
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2002-2211
- 2026-10-03 Alias added: GHSA-566q-9c9p-9jc4
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2002-2211 · CVE Program
- CVE-2002-2211 · NVD
- FIRST EPSS
- GHSA-566q-9c9p-9jc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences