The Catalina org.apache.catalina.connector.http package in Tomcat 4.0.x up to 4.0.3…
Priority MEDIUM 48CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
The Catalina org.apache.catalina.connector.http package in Tomcat 4.0.x up to 4.0.3 allows remote attackers to cause a denial of service via several requests that do not follow the HTTP protocol, which causes Tomcat to reject later requests.
Why it matters now
EPSS 0.34816 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.tomcat:tomcat (Maven): 4.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.tomcat:tomcat (Maven) | 4.0 to before 4.1.0 | 4.1.0 | Patch available | GHSA-7wj2-48c4-2684 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.tomcat:tomcat (Maven) Vendor— Affected 4.0 to before 4.1.0 Fixed in 4.1.0 Patch available GHSA-7wj2-48c4-2684
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* | 4.0.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* | 4.0.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.5:*:*:*:*:*:*:* | 4.0.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:4.0.6:*:*:*:*:*:*:* | 4.0.6 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.5:*:*:*:*:*:*:* Versions 4.0.5 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:4.0.6:*:*:*:*:*:*:* Versions 4.0.6 Vulnerable ·Apache
Remediation
- Fix · GHSA-7wj2-48c4-2684 org.apache.tomcat:tomcat (Maven) Fixed in 4.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2003-0866
- 2026-10-03 Alias added: GHSA-7wj2-48c4-2684
References
Patch 1
Other 8
- http://tomcat.apache.org/security-4.html
- ADV-2008-1979
- [tomcat-dev] 20190319 svn commit: r1855831 [21/30] - in /tomcat/site/trunk: ./ docs/ xdocs/
- [tomcat-dev] 20190325 svn commit: r1856174 [19/29] - in /tomcat/site/trunk: docs/ xdocs/ xdocs/stylesheets/
- [tomcat-dev] 20200213 svn commit: r1873980 [24/34] - /tomcat/site/trunk/docs/
- https://lists.apache.org/thread.html/29dc6c2b625789e70a9c4756b5a327e6547273ff8bde7e0327af48c5@%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/c62b0e3a7bf23342352a5810c640a94b6db69957c5c19db507004d74@%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/rb71997f506c6cc8b530dd845c084995a9878098846c7b4eacfae8db3@%3Cdev.tomcat.apache.org%3E
More Apache Tomcat vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2016-07192 Improper access control in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2017-09342 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2017-09340 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2026-26741 Apache Tomcat: Fix for CVE-2026-29146 allowed bypass of EncryptInterceptor KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2003-0866 · CVE Program
- CVE-2003-0866 · NVD
- FIRST EPSS
- GHSA-7wj2-48c4-2684 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences