AWStats 6.1, and other versions before 6.3, allows remote attackers to execute arbitrary…
Priority HIGH 72CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA.
Summary
AWStats 6.1, and other versions before 6.3, allows remote attackers to execute arbitrary commands via shell metacharacters in the configdir parameter to aswtats.pl.
Why it matters now
EPSS 0.74941 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2005-0116
- 2026-10-03 Alias added: GHSA-3vg9-7c42-3mxf
References
More Awstats vulnerabilities
- TI-2006-02178 The web interface for AWStats 6.4 and 6.5, when statistics updates are enabled, allows… CVSS 2.0MEDIUM 5.1
- TI-2010-04100 awstats.cgi in AWStats before 7.0 accepts a configdir parameter in the URL, which allows… CVSS 2.0HIGH 7.5
- TI-2020-17782 In AWStats through 7.7, cgi-bin/awstats.pl?config= accepts an absolute pathname, even… CVSS 3.1CRITICAL 9.8
- TI-2017-14709 Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of… CVSS 3.0CRITICAL 9.8
- TI-2005-00394 Direct code injection vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote… CVSS 2.0HIGH 7.5
- TI-2025-39268 AWStats 8.0 is vulnerable to Command Injection via the open function CVSS 3.1HIGH 7.8
Sources
- CVE-2005-0116 · CVE Program
- CVE-2005-0116 · NVD
- FIRST EPSS
- GHSA-3vg9-7c42-3mxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences