system/workplace/views/admin/admin-main.jsp in Alkacon OpenCms before 6.2.2 does not…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
system/workplace/views/admin/admin-main.jsp in Alkacon OpenCms before 6.2.2 does not restrict access to administrator functions, which allows remote authenticated users to (1) send broadcast messages to all users (/workplace/broadcast), (2) list all users (/accounts/users), (3) add webusers (/accounts/webusers/new), (4) upload database import and export files (/database/importhttp), (5) upload arbitrary program modules (/modules/modules_import), and (6) read the log file (/workplace/logfileview) by setting the appropriate value for the path parameter in a direct request to admin-main.jsp.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.opencms:opencms-core (Maven) | before 6.2.2 | 6.2.2 | Patch available | GHSA-v3c3-qr6m-8m7m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.opencms:opencms-core (Maven) Vendor— Affected before 6.2.2 Fixed in 6.2.2 Patch available GHSA-v3c3-qr6m-8m7m
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:alkacon:opencms:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.2:*:*:*:*:*:*:* | 6.0.2 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.3:*:*:*:*:*:*:* | 6.0.3 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.4:*:*:*:*:*:*:* | 6.0.4 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.2:*:*:*:*:*:*:* | 6.2 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.2.1:*:*:*:*:*:*:* | 6.2.1 | Vulnerable | Alkacon |
- cpe:2.3:a:alkacon:opencms:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.2:*:*:*:*:*:*:* Versions 6.0.2 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.3:*:*:*:*:*:*:* Versions 6.0.3 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.4:*:*:*:*:*:*:* Versions 6.0.4 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.2:*:*:*:*:*:*:* Versions 6.2 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.2.1:*:*:*:*:*:*:* Versions 6.2.1 Vulnerable ·Alkacon
Remediation
- Fix · GHSA-v3c3-qr6m-8m7m org.opencms:opencms-core (Maven) Fixed in 6.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-3935
- 2026-10-03 Alias added: GHSA-v3c3-qr6m-8m7m
References
Patch 3
More Alkacon Opencms vulnerabilities
- TI-2024-28583 Cross Site Scripting vulnerability in Create/Modify article function in Alkacon OpenCMS… CVSS 3.1MEDIUM 6.5
- TI-2023-19187 An arbitrary file upload vulnerability in the component /workplace#!explorer of Alkacon… CVSS 3.1MEDIUM 6.1
- TI-2024-27633 A stored cross-site scripting (XSS) vulnerability in Alkacon OpenCMS v17.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2024-27632 A stored cross-site scripting (XSS) vulnerability in Alkacon OpenCMS v17.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2023-15113 A stored cross-site scripting (XSS) vulnerability in alkacon-OpenCMS v11.0.0.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2021-07974 OpenCMS - Stored Cross-Site Scripting (XSS) in Sitemap CVSS 3.1MEDIUM 5.4
Sources
- CVE-2006-3935 · CVE Program
- CVE-2006-3935 · NVD
- FIRST EPSS
- GHSA-v3c3-qr6m-8m7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences