system/workplace/editors/editor.jsp in Alkacon OpenCms before 6.2.2 allows remote…
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
system/workplace/editors/editor.jsp in Alkacon OpenCms before 6.2.2 allows remote authenticated users to read the source code of arbitrary JSP files by specifying the file in the resource parameter, as demonstrated using index.jsp.
Why it matters now
EPSS 0.01382 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.opencms:opencms-core (Maven): 6.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.opencms:opencms-core (Maven) | before 6.2.2 | 6.2.2 | Patch available | GHSA-c5vw-342h-x5rx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.opencms:opencms-core (Maven) Vendor— Affected before 6.2.2 Fixed in 6.2.2 Patch available GHSA-c5vw-342h-x5rx
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:alkacon:opencms:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.2:*:*:*:*:*:*:* | 6.0.2 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.3:*:*:*:*:*:*:* | 6.0.3 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.0.4:*:*:*:*:*:*:* | 6.0.4 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.2:*:*:*:*:*:*:* | 6.2 | Vulnerable | Alkacon |
| cpe:2.3:a:alkacon:opencms:6.2.1:*:*:*:*:*:*:* | 6.2.1 | Vulnerable | Alkacon |
- cpe:2.3:a:alkacon:opencms:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.2:*:*:*:*:*:*:* Versions 6.0.2 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.3:*:*:*:*:*:*:* Versions 6.0.3 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.0.4:*:*:*:*:*:*:* Versions 6.0.4 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.2:*:*:*:*:*:*:* Versions 6.2 Vulnerable ·Alkacon
- cpe:2.3:a:alkacon:opencms:6.2.1:*:*:*:*:*:*:* Versions 6.2.1 Vulnerable ·Alkacon
Remediation
- Fix · GHSA-c5vw-342h-x5rx org.opencms:opencms-core (Maven) Fixed in 6.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-3936
- 2026-10-03 Alias added: GHSA-c5vw-342h-x5rx
References
Patch 2
More Alkacon Opencms vulnerabilities
- TI-2024-28583 Cross Site Scripting vulnerability in Create/Modify article function in Alkacon OpenCMS… CVSS 3.1MEDIUM 6.5
- TI-2023-19187 An arbitrary file upload vulnerability in the component /workplace#!explorer of Alkacon… CVSS 3.1MEDIUM 6.1
- TI-2024-27633 A stored cross-site scripting (XSS) vulnerability in Alkacon OpenCMS v17.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2024-27632 A stored cross-site scripting (XSS) vulnerability in Alkacon OpenCMS v17.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2023-15113 A stored cross-site scripting (XSS) vulnerability in alkacon-OpenCMS v11.0.0.0 allows… CVSS 3.1MEDIUM 5.4
- TI-2021-07974 OpenCMS - Stored Cross-Site Scripting (XSS) in Sitemap CVSS 3.1MEDIUM 5.4
Sources
- CVE-2006-3936 · CVE Program
- CVE-2006-3936 · NVD
- FIRST EPSS
- GHSA-c5vw-342h-x5rx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences