Read the docs
TI-2006-03970 Aliases CVE-2006-4096GHSA-qwch-fhfg-fr39

BIND before 9.2.6-P1 and 9.3.x before 9.3.2-P1 allows remote attackers to cause a denial…

Priority LOW 34Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.

Summary

BIND before 9.2.6-P1 and 9.3.x before 9.3.2-P1 allows remote attackers to cause a denial of service (crash) via a flood of recursive queries, which cause an INSIST failure when the response is received after the recursion queue is empty.

Why it matters now

EPSS 0.08325 94th percentileScored 2026-11-07
Fix Fixed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 11

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.2.0:*:*:*:*:*:*:*9.2.0VulnerableISC
cpe:2.3:a:isc:bind:9.2.1:*:*:*:*:*:*:*9.2.1VulnerableISC
cpe:2.3:a:isc:bind:9.2.2:*:*:*:*:*:*:*9.2.2VulnerableISC
cpe:2.3:a:isc:bind:9.2.3:*:*:*:*:*:*:*9.2.3VulnerableISC
cpe:2.3:a:isc:bind:9.2.4:*:*:*:*:*:*:*9.2.4VulnerableISC
cpe:2.3:a:isc:bind:9.2.5:*:*:*:*:*:*:*9.2.5VulnerableISC
cpe:2.3:a:isc:bind:9.2.6:*:*:*:*:*:*:*9.2.6VulnerableISC
cpe:2.3:a:isc:bind:9.3:*:*:*:*:*:*:*9.3VulnerableISC
cpe:2.3:a:isc:bind:9.3.0:*:*:*:*:*:*:*9.3.0VulnerableISC
cpe:2.3:a:isc:bind:9.3.1:*:*:*:*:*:*:*9.3.1VulnerableISC
  • cpe:2.3:a:isc:bind:9.2.0:*:*:*:*:*:*:* Versions 9.2.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.1:*:*:*:*:*:*:* Versions 9.2.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.2:*:*:*:*:*:*:* Versions 9.2.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.3:*:*:*:*:*:*:* Versions 9.2.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.4:*:*:*:*:*:*:* Versions 9.2.4 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.5:*:*:*:*:*:*:* Versions 9.2.5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.2.6:*:*:*:*:*:*:* Versions 9.2.6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.3:*:*:*:*:*:*:* Versions 9.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.3.0:*:*:*:*:*:*:* Versions 9.3.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.3.1:*:*:*:*:*:*:* Versions 9.3.1 Vulnerable ·ISC
Show 1 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.3.2:*:*:*:*:*:*:*9.3.2VulnerableISC
  • cpe:2.3:a:isc:bind:9.3.2:*:*:*:*:*:*:* Versions 9.3.2 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Desktop version 3Fixed—
Red Hat Enterprise Linux AS version 3Fixed—
Red Hat Enterprise Linux AS version 4Fixed—
Red Hat Enterprise Linux Desktop version 4Fixed—
Red Hat Enterprise Linux ES version 3Fixed—
Red Hat Enterprise Linux ES version 4Fixed—
Red Hat Enterprise Linux WS version 3Fixed—
Red Hat Enterprise Linux WS version 4Fixed—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2006-4096
  2. 2026-10-03 Alias added: GHSA-qwch-fhfg-fr39
  3. 2026-10-14 EPSS moved to the 95th–99th percentile
  4. 2026-10-23 EPSS moved to the 90th–95th percentile

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources